Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

23 Март 2017, 15:20 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Здесь можно поблагодарить участников форума Улыбка
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: не запускается LanguageTool в LibreOffice под Win 10, Java 1.8.0_111 установ...  (Прочитано 678 раз)
0 Пользователей и 1 Гость смотрят эту тему.
ForumOOo (бот)
Ветеран
*****
Offline Offline

Сообщений: 566


« Стартовое сообщение: 22 Декабрь 2016, 23:12 »

Компонент: Extension
Версия продукта: 5.x
Сборка: LibreOffice
ОС: Windows 10

не запускается LanguageTool в LibreOffice под Win 10, Java 1.8.0_111 установлен. В Chrome LanguageTool
есть.

--
Подпись: Val
Записан
Yakov
Администратор
*
Offline Offline

Сообщений: 2 186


WWW
« Ответ #1: 23 Декабрь 2016, 00:01 »

LibreOffice 5.x может быть как 32-битным, так и 64-битным.
Для 32-битной версии LibreOffice 5.x надо использовать 32-битную версию Java,
а для 64-битной версии LibreOffice 5.x надо использовать 64-битную версию Java.
В настройках LO должна быть выбрана соответствующая версия Java.
Кроме того, в языковых настройках LO необходимо отключить Lightproof-ru.
Эти изменения в настройках LO вступают в силу после перезапуска LO (необходимо закрыть все открытые окна LO).


Список известных проблем и способов их решения
« Последнее редактирование: 23 Декабрь 2016, 00:05 от Yakov » Записан

economist
Старожил
****
Offline Offline

Сообщений: 442


« Ответ #2: 23 Декабрь 2016, 08:45 »

Добавлю что кроме соответствия по битности JAVA - также должны соответствовать по битности и драйверы ODBC для работы OpenOffice|LibreOffice BASE, если они используются.

На практике всё это привело к тому что на зоопарке из 500 машин пришлось вывести в 0 все 64-битные LibreOffice. 32-х битные работают не хуже, а даже лучше.

Для OpenOffice|LibreOffice есть хорошая 32-х битная
portable Java, которая работает на 250 машинах без малейших намеков на проблему, не обновляется и не плодит значков в трее.  

http://portableapps.com/apps/utilities/java_portable

Там же есть и 64-х битная, их ничто не мешает иметь обе.
Записан

Руб. за сто, что Питоньяк
Любит водку и коньяк!
Потому что мне, без оных, -
Не понять его никак...
Yakov
Администратор
*
Offline Offline

Сообщений: 2 186


WWW
« Ответ #3: 23 Декабрь 2016, 08:55 »

Добавлю что кроме соответствия по битности JAVA - также должны соответствовать по битности и драйверы ODBC для работы OpenOffice|LibreOffice BASE, если они используются.
Это к LanguageTool не относится.
Записан

Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!