Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

21 Октябрь 2017, 13:12 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Здесь можно поблагодарить участников форума Улыбка
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: [Решено] Сравнение формулой массива не-работает как исправить?  (Прочитано 256 раз)
0 Пользователей и 1 Гость смотрят эту тему.
vk
Новичок
*
Offline Offline

Пол: Мужской
Сообщений: 12


« Стартовое сообщение: 29 Июль 2017, 14:08 »

Код:
{=ЕСЛИ(И(L1.A4>= Диапазону любой одной строки из $A$4:$A$10)*(L1.A4<=$B$4:$B$10)*(L1.B4>=$C$4:$C$10)*(L1.B4<=$D$4:$D$10)*(L1.D4>=$E$4:$E$10)*(L1.D4<=$F$4:$F$10)*(L1.F4>=$G$4:$G$10)*(L1.F4<=$H$4:$H$10);1;0)}
Формула сравнивает критерий на Листе.1 с диапазоном на Листе.2. В примере на Листе.1 9 строка соответствует одной из строк диапазона на Листе.2, далее аналогично 17 строка соответствует...

* Сравнение .ods (65.65 Кб - загружено 3 раз.)
« Последнее редактирование: 31 Июль 2017, 21:52 от vk » Записан
JohnSUN
Капитана в тот день называли на "ты"
Гуру
*******
Offline Offline

Пол: Мужской
Расположение: Киев
Сообщений: 2 346


Помогаю людям и компьютерам понимать друг друга


WWW
« Ответ #1: 31 Июль 2017, 10:47 »

Ну, даже не знаю... А ты хочешь обязательно воткнуть туда именно формулу массива? Может быть достаточно будет SUMPRODUCT(СУММПРОИЗВ)? Что-то вроде
Код:
=СУММПРОИЗВ((L1.A4>=$A$4:$A$10);(L1.A4<=$B$4:$B$10);
        (L1.B4>=$C$4:$C$10);(L1.B4<=$D$4:$D$10);
        (L1.D4>=$E$4:$E$10);(L1.D4<=$F$4:$F$10);
        (L1.F4>=$G$4:$G$10);(L1.F4<=$H$4:$H$10))

PS. Эти строчки в свойствах документа (см. скриншот) - производят впечатление... Ты бы сбрасывал иногда их в ноль. Был когда-то давно глюк, связанный с превышением времени работы с документом выше какого-то порогового значения: в какой-то момент вся книга превращалась в груду мусора. Сейчас-то этот баг, кажется(!), исправлен. Но где гарантия, что кто-нибудь не попытается открыть твою книгу в очень старой версии офиса?


* Ветеран редактирования.png (1.75 Кб, 255x70 - просмотрено 10 раз.)
Записан

Владислав Орлов aka JohnSUN
Благодарить-не зазорно.
Подарить благо создателям офиса, нашему ресурсу, мне
economist
Ветеран
*****
Offline Offline

Сообщений: 715


« Ответ #2: 31 Июль 2017, 12:17 »

Пишу инструкцию к музыкальному редактору Reaper уже 6 лет, глянул в свойства и...


* 50 дней правок за 6 лет.jpg (47.79 Кб, 534x456 - просмотрено 13 раз.)
Записан

Руб. за сто, что Питоньяк
Любит водку и коньяк!
Потому что мне, без оных, -
Не понять его никак...
vk
Новичок
*
Offline Offline

Пол: Мужской
Сообщений: 12


« Ответ #3: 31 Июль 2017, 21:47 »

Цитата:
А ты хочешь обязательно воткнуть туда именно формулу массива?
Да вот сложилась у меня ассоциация такая при сравнении 3 000 строк по 8 столбцов сразу вспоминаю массив Непонимающий
Цитата:
Может быть достаточно будет SUMPRODUCT(СУММПРОИЗВ)?
Это работает я получил желаемый результат  Всё хорошо Благодарю за помощь
Цитата:
PS. Эти строчки в свойствах документа (см. скриншот) - производят впечатление...
Это всё от дефицита знаний, после многочисленных проб и ошибок это начинает работать.
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!