Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

18 Октябрь 2017, 17:52 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Вы можете задать вопрос по LibreOffice или Apache OpenOffice  без регистрации, используя форму
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: Краш LibreOffice Base (Ubuntu 17.04, LO 5.3.1.2)  (Прочитано 1349 раз)
0 Пользователей и 1 Гость смотрят эту тему.
NicholasLibre
Новичок
*
Offline Offline

Сообщений: 13


« Стартовое сообщение: 29 Июль 2017, 22:45 »


Господа, не могу вообще запустить LibreOffice Base. Падает сразу после запуска при попытке что-нибудь сделать. Вот ссылки на схожие или идентичные проблемы 

https://askubuntu.com/questions/940982/libreoffice-base-crashing
https://ubuntuforums.org/showthread.php?t=2364249

Processor: Intel Pentium T4400 @ 2.20GHz (2 Cores), Motherboard: LENOVO KIWB1, Chipset: Intel Mobile 4 MCH + ICH9M, Memory: 2048MB, Disk: 320GB Seagate ST320LM001 HN-M3, Graphics: NVA5 1024MB, Audio: Realtek ALC272, Network: Broadcom Limited NetLink BCM5784M Gigabit PCIe + Broadcom Limited BCM4312 802.11b/g

Software:
OS: Ubuntu 17.04, Kernel: 4.10.0-26-generic (i686), Desktop: Xfce 4.12, Display Driver: modesetting 1.19.3, OpenGL: 3.3 Mesa 17.2.0-devel, Compiler: GCC 6.3.0 20170406, File-System: ext4, Screen Resolution: 1366x768

Версия: 5.3.1.2
ID сборки: 1:5.3.1-0ubuntu2
Потоков ЦП: 2; Версия ОС: Linux 4.10; Отрисовка ИП: по умолчанию; VCL: gtk2; Способ разметки: новый;
Локаль: ru-RU (ru_RU.UTF-8); Calc: group

Ставил и пробовал с Oracle JDK, gtk3 вроде тоже пробовал. Всё тоже самое. Плачущий Плачущий Плачущий
Записан
mikekaganski
Ветеран
*****
Offline Offline

Пол: Мужской
Расположение: Хабаровск -> Москва
Сообщений: 612


« Ответ #1: 29 Июль 2017, 22:49 »

https://lwn.net/Articles/727206/
https://lwn.net/Articles/727703/
https://lwn.net/Articles/727705/
Записан

С уважением,
Михаил Каганский
NicholasLibre
Новичок
*
Offline Offline

Сообщений: 13


« Ответ #2: 29 Июль 2017, 23:05 »

Спасибо большое за оперативный и содержательный ответ ! Это уже меня очень радует )). Насколько я понял проблема в архитектуре процессора 32-х битного, новой версии ядра Linux и Java. Даже Линус Торвальдс занимается... Да уж... Но я не совсем понял решён ли сейчас вопрос ? Если можно поясните пожалуйста этот момент. Я так понял какой-то патч разработали, но как всё это применить...
Записан
mikekaganski
Ветеран
*****
Offline Offline

Пол: Мужской
Расположение: Хабаровск -> Москва
Сообщений: 612


« Ответ #3: 29 Июль 2017, 23:11 »

Я не знаю, можно ли применить какие-то патчи. Но мне кажется, что сейчас пока что поможет только откат обновлений ядра (если, конечно, у Вас проблема именно эта - не факт, т.к. по второй Вашей ссылке у человека на ядре 4.10.0.27 всё работает).
Записан

С уважением,
Михаил Каганский
NicholasLibre
Новичок
*
Offline Offline

Сообщений: 13


« Ответ #4: 29 Июль 2017, 23:32 »

А что делать ? У меня система изначально поставлена 17.04. Могу попробовать поставить 16.04... Вот насколько я понимаю репорт по данному багу - обновляется почти каждый день - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1699772 ...
Записан
maksvlad
Пользователь
**
Offline Offline

Сообщений: 67


« Ответ #5: 1 Август 2017, 11:02 »

может попробовать поставить 17.04 64bit (amd64) ?
процессор поддерживает же...
Памяти, понимаю, маловато. Но с таким количеством памяти и 32бит свопиться должно жестко
Записан
NicholasLibre
Новичок
*
Offline Offline

Сообщений: 13


« Ответ #6: 1 Август 2017, 12:12 »

Серьёзно ? На мой intel t4400 можно поставить amd64 ?

https://ark.intel.com/ru/products/40739/Intel-Pentium-Processor-T4400-1M-Cache-2_20-GHz-800-MHz-FSB-Socket-P
Записан
Slavka
Новичок
*
Offline Offline

Сообщений: 18


« Ответ #7: 1 Август 2017, 14:14 »

Можно-можно, только памяти добавить.
Записан
maksvlad
Пользователь
**
Offline Offline

Сообщений: 67


« Ответ #8: 1 Август 2017, 14:41 »

Серьёзно ? На мой intel t4400 можно поставить amd64 ?

https://ark.intel.com/ru/products/40739/Intel-Pentium-Processor-T4400-1M-Cache-2_20-GHz-800-MHz-FSB-Socket-P
По ссылке 
Архитектура Intel® 64 ‡ Да
Набор команд 64-bit

Память, хотя бы 4GB, и как офисная машинка будет шуршать. Тем более, что окружение XFCE используется
Записан
NicholasLibre
Новичок
*
Offline Offline

Сообщений: 13


« Ответ #9: 1 Август 2017, 17:23 »

Мне за глаза хватает 2 гигабайтов на linux xubuntu, быстрее форточной системы в 3-4 раза, аналогично с потреблением ресурсов. Я установил 64-bit систему (что для меня оказалось большим открытием что процессор поддерживает таки), бог с этим base надеюсь они пофиксят, я думал что 64-битной у меня может графика нормально заработает, ан нет. Если интересно - https://devtalk.nvidia.com/default/topic/1020418/linux/lenovo-y550-gt-m240-vs-ubuntu-17-07-16-04-14-04/
Записан
maksvlad
Пользователь
**
Offline Offline

Сообщений: 67


« Ответ #10: 2 Август 2017, 05:40 »

Это уже оффтопик, но возможно попробовать установку драйвера не через диспетчер убунтовский, а через run-файл от нвидиа. Его, правда, надо запускать с отключенными Иксами, но от него остается лог, как установился и где пошло не так.
Записан
NicholasLibre
Новичок
*
Offline Offline

Сообщений: 13


« Ответ #11: 13 Август 2017, 19:04 »

Так, путём немыслимых усилий была налажена графика nvidia - проблема была в bios Lenovo, это оффтоп. Сейчас у меня последний драйвер nvidia работает и последний Версия: 5.4.0.3 ID сборки: 1:5.4.0~rc3-0ubuntu0.17.04.1~lo0 Потоков ЦП: 2; ОС:Linux 4.10; Отрисовка ИП: по умолчанию; VCL: gtk3;  Локаль: ru-RU (ru_RU.UTF-8); Calc: group .

Libreoffice Base - по-прежнему крашится.
Записан
maksvlad
Пользователь
**
Offline Offline

Сообщений: 67


« Ответ #12: 14 Август 2017, 11:47 »

А почему  VCL: gtk3??? может надо gtk2??? самое стабильное из того, что пользовал
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!