Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

20 Июнь 2018, 14:26 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Вы можете задать вопрос по LibreOffice или Apache OpenOffice  без регистрации, используя форму
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: Проблемы с rtf в LO5 под Дебиан9  (Прочитано 639 раз)
0 Пользователей и 1 Гость смотрят эту тему.
ЦарьПушка
Новичок
*
Offline Offline

Сообщений: 3


« Стартовое сообщение: 4 Декабрь 2017, 14:09 »

Не знаю, как точно сформулировать проблему, возможно этот вопрос и задавался.
Лучше сделаю скриншот.

Там поля для заполнения, и под Убунтами 12.04, 14.04 и 16.04 они были без чёрной заливки под LO 3,4,5

В Debian 9 же проблема, всё черно.
Возможно надо добавить что-то в LO. под убунтами я обычно ничего, кроме pager, не ставил
Записан
rami
Гуру
*******
Offline Offline

Пол: Мужской
Сообщений: 2 485


MacBook Pro, LibreOffice и Apache OpenOffice


« Ответ #1: 4 Декабрь 2017, 14:29 »

Для начала проверьте настройки цвета полей: в параметрах офиса, вкладка "Внешний вид" пункт "Затенение полей", попробуйте разные варианты (с птичкой или без, подходящий цвет)


* Затенение полей.png (101.1 Кб, 800x385 - просмотрено 14 раз.)
Записан

ЦарьПушка
Новичок
*
Offline Offline

Сообщений: 3


« Ответ #2: 6 Декабрь 2017, 19:34 »

Для начала проверьте настройки цвета полей: в параметрах офиса, вкладка "Внешний вид" пункт "Затенение полей", попробуйте разные варианты (с птичкой или без, подходящий цвет)
Проверил.
Пепробовал разные варианты и в этом пункте, и других.
Ни разу не помогло.
Записан
greenman
Постоялец
***
Offline Offline

Сообщений: 238


« Ответ #3: 8 Декабрь 2017, 09:52 »

Попробовать отключить аппаратное ускорение.

Вариант - поставить libreoffice из backports.

Погуглил rtf из системы гарант

Нашёл немного похожий, чёрным поля не заливает.

Но таблица в шапке съехала.

Код:
Версия: 5.3.7.2.0
...
Версия ОС: Linux 4.14; Отрисовка ИП: по умолчанию; VCL: gtk3; Способ разметки: новый;

* 13.3.rtf (64.86 Кб - загружено 8 раз.)
« Последнее редактирование: 8 Декабрь 2017, 10:09 от greenman » Записан
rami
Гуру
*******
Offline Offline

Пол: Мужской
Сообщений: 2 485


MacBook Pro, LibreOffice и Apache OpenOffice


« Ответ #4: 8 Декабрь 2017, 10:30 »

Но таблица в шапке съехала.
Открыл ваш документ на Маке в LibreOffice (разные) — первая таблица тоже съехала вправо, а Apache OpenOffice 4.1.3 открывает нормально. Видимо, есть баг в LibreOffice.

ЦарьПушка, попробуйте для работы с .rtf Apache OpenOffice, LibreOffice сносить не нужно.
Записан

mikekaganski
Ветеран
*****
Offline Offline

Пол: Мужской
Расположение: Хабаровск -> Москва
Сообщений: 932


« Ответ #5: 8 Декабрь 2017, 12:36 »

@rami: tdf#114333
Записан

С уважением,
Михаил Каганский
ЦарьПушка
Новичок
*
Offline Offline

Сообщений: 3


« Ответ #6: 10 Декабрь 2017, 13:43 »

А ларчик просто открывался:
Таблица - Свойства - Фон - заливка - без заливки)

Но когда снял заливку, выяснилось, что поля разъехались.
Под Убунтой такое было, когда поял разъезжались, под толи вторым то ли третьим LO - какой там шёл с Ubeuntu 12.04?.
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!