Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

26 Апрель 2018, 14:37 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Часто задаваемые вопросы по LibreOffice и Apache OpenOffice.org
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: « 1 2   Вниз
  Печать  
Автор Тема: Cтиль абзаца самопроизвольно переключается в Базовый  (Прочитано 758 раз)
0 Пользователей и 1 Гость смотрят эту тему.
kompilainenn
Ветеран
*****
Offline Offline

Сообщений: 2 312



« Ответ #15: 30 Март 2018, 22:46 »

модераторы разделите тему пожалуйста
Записан

Поддержать разработчиков LibreOffice можно тут, а наш форум вот тут
Helen
Администратор
*
Offline Offline

Пол: Женский
Расположение: Екатеринбург
Сообщений: 2 511


WWW
« Ответ #16: 31 Март 2018, 07:06 »

модераторы разделите тему пожалуйста
спасибо. Я разделю тему, если участники пожелают продолжить конструктивное обсуждение нюансов сборки из исходников.
Записан
McAaron
Постоялец
***
Offline Offline

Сообщений: 239


« Ответ #17: 2 Апрель 2018, 12:32 »

Насчёт качания исходников с официальных билдов - это можно делать, вот только нафига. Потому что даже собрав такой релиз, и даже поправив там что-то, Вы не сможете отправить правку в проект: работа над патчами идёт не на базе релизов, а в текущих ветках.

А насчёт "./configure --with-system-libs" - в документации нет ни слова о ./configure. Мы так не настраиваем проект.
./configure вызывается автогеном, котороый передает ему все опции, не рефлексируя. Насколько я понимаю, если есть для конфигуратора необычная опция, то ее прописали туда явно с определенной целью.
Насчет вашей настройки все просто -- вы тянете все эти либы со своих серваков. Я, например, так не могу -- есть политика конторы, которая требует, чтобы весь софт, производящий софт из исходников, запускался изолировано от внешней сети.
Фактически, пока версия пакета не войдет в распространенные дистрибутивы, ей пользоваться не получается. Такая же ситуация с wxPyton, но пока еще собирается с системной версией xwWidget
Если я клонирую офис с репозитория, полезет ли make в интернет?


« Последнее редактирование: 2 Апрель 2018, 12:40 от McAaron » Записан
tagezi
Ветеран
*****
Offline Offline

Пол: Мужской
Расположение: Finland
Сообщений: 782



WWW
« Ответ #18: 2 Апрель 2018, 14:47 »

./configure --with-system-libs, процесс завершается на стадии конфигурирования -- уж слишком "свежей" xmlsec1-nss требует версия офиса 5.4.6.2.
В документации, на которую вы кстати ссылались, сказано:
Цитата:
Building with existing libraries may speed up your build, but you have to fiddle with the dependencies.
Если не понятно слово сочетание "you have to fiddle" - "Вы обязаны играть на скрипке", то на русский его, наверное, лучше перевести как, "все проблемы, которые вы получаете, будете решать самостоятельно."
Вы конечно можете написать в рассылку разработчиков, может вам кто-то поможет.

Я, например, так не могу -- есть политика конторы, которая требует, чтобы весь софт, производящий софт из исходников, запускался изолировано от внешней сети.
Фактически, пока версия пакета не войдет в распространенные дистрибутивы, ей пользоваться не получается.
Делается патч в мастер, а затем бекпортится, пока хватает сил. Так делают все, и Callabora, и RedHat, и CIB Software, компании, которые зарабатывают на поддержке.
В вашем случае (то как вы хотите), вы поправите только в одной минорной версии, а дальше будете исправлять это место в каждой следующей снова и снова. И вам очень сильно повезёт, если этот кусок и его зависимые части не будут трогаться.
Записан

(x86_64) Kubuntu 16.04.3 - LibreOffice 6.0.2 / 6.1 alpha
Страниц: « 1 2   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!