Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

23 Июль 2018, 09:10 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Здесь можно поблагодарить участников форума Улыбка
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: В столбцах А и В таблицы Calc используется условное форм?...  (Прочитано 323 раз)
0 Пользователей и 1 Гость смотрят эту тему.
ForumOOo (бот)
Ветеран
*****
Offline Offline

Сообщений: 645


« Стартовое сообщение: 15 Май 2018, 08:56 »

Компонент: Calc
Версия продукта: 5.x
Сборка: LibreOffice
ОС: Win 8.1 x64

В столбцах А и В таблицы Calc используется условное форматирование -
заливка цветом повторяющихся значений. Нужно отсортировать таблицу
следующим образом - первыми вывести в порядке возрастания все
ПОВТОРЯЮЩИЕСЯ значения столбца А (для копирования), сортировка не
повторяющихся значений не важна. Затем также отсортировать в порядке
возрастания все повторяющиеся значения в столбце В. Возможно ли решение?

--
Подпись: Анна
Записан
JohnSUN
Капитана в тот день называли на "ты"
Гуру
*******
Offline Offline

Пол: Мужской
Расположение: Киев
Сообщений: 2 504


Помогаю людям и компьютерам понимать друг друга


WWW
« Ответ #1: 15 Май 2018, 10:52 »

Да, Анна, решение есть. Только оно связано не с цветом выделенных ячеек, а с их значениями.
В свободном столбце рядом с таблицей впишите формулу
Код:
=COUNTIF(A:A;A2)
или
Код:
=СЧЁТЕСЛИ(A:A;A2)
если Calc не хочет видеть английские имена функций
Растяните эту формулу до конца таблицы, выделите все данные (и исходную таблицу, и вспомогательный столбец)
Теперь можете использовать меню Данные-Ещё фильтры-Стандартный фильтр (см. картинку)


* Отобрать дубли.png (16.99 Кб, 441x382 - просмотрено 7 раз.)
« Последнее редактирование: 15 Май 2018, 10:53 от JohnSUN » Записан

Владислав Орлов aka JohnSUN
Благодарить-не зазорно.
Подарить благо создателям офиса, нашему ресурсу, мне
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!