Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

22 Август 2018, 01:17 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Часто задаваемые вопросы по LibreOffice и Apache OpenOffice.org
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: LibreOffice vs Java  (Прочитано 386 раз)
0 Пользователей и 1 Гость смотрят эту тему.
PaulEfremoff
Новичок
*
Offline Offline

Сообщений: 1


« Стартовое сообщение: 3 Август 2018, 19:12 »

Вечная, сколько себя помню, проблема с запуском Java.
На данный момент выглядит так:
1. Последняя версия Windows 10 Pro 1803 сборка 17134.165
2. Последняя версия LibreOffice: 6.0.5.2
3. Последняя версия Java 8.0.181 c oracle.com
4. Все галочки выставлены, разрядность соответствует, вчера всё работало, сегодня перестало, мамой клянусь - ничего не трогал.
5. Раньше, так как это случалось не слишком часто, выручала переустановка чего-нибудь на свежую версию. Сейчас отступать некуда, буквально всё последней версии.

Сообщение о смерти Java:

Для выполнения данного задания LibreOffice необходимо установленное окружение Java (JRE). Выбранное JRE неисправно. Пожалуйста, выберите другую версию или установите новую, затем выберите её в Сервис - Параметры - LibreOffice - Расширенные возможности.

Ошибка сценария при выполнении сценария Java <имярек>
Сообщение: Язык сценариев Java не поддерживается.

Люди! Когда это кончится, или пора сваливать из LibreOffice'а?

P.S. Переустановка всего не помогла. На более старой Windows 2016г. всё то же работает. Походу кто-то чего-то куда-то в Windows прописал, LibreOffice эту хрень находит и работать отказывается.
« Последнее редактирование: 3 Август 2018, 20:51 от PaulEfremoff » Записан
mikekaganski
Ветеран
*****
Offline Offline

Пол: Мужской
Расположение: Хабаровск -> Москва
Сообщений: 990


« Ответ #1: 3 Август 2018, 19:19 »

Вы вчера не обновляли Java? А то вон как раз про 1.8.0_181 пишут нехорошее...

Хотя нет, вру, не пишут; подозрения там не подтвердились.
« Последнее редактирование: 3 Август 2018, 19:21 от mikekaganski » Записан

С уважением,
Михаил Каганский
economist
Ветеран
*****
Offline Offline

Сообщений: 904


« Ответ #2: 4 Август 2018, 15:28 »

Я очень редко, но вижу "Выбранное JRE неисправно", но только на тех из 250 PC, где:
- не-portable JAVA (jPortable)
- не-portable LO 5/6

Такие ещё остались 14 штук (чтобы уверенно писать в т.ч. и здесь), даже в моем кабинете. Впрочем, можно и на portable увидеть такое сообщение: стоит лишь попытаться задать безобидные параметры запуска JVM вида (с целью, скажем, увеличить память до NNN, чтобы уйти от Heap Memory error):
-XmsNNNm
-XmxNNNm
-XssNNNm
...и погонять LO Wirter/Calc/Base на чем-то серьезнее, чем Biblio, например с sqlite-базой, через JDBC, размером эдак на 5-10 Гб. 

jPortable не пытается сам обновиться, и этим он прекрасен. Просто работает одинаково: и год назад, и завтра.
« Последнее редактирование: 4 Август 2018, 15:34 от economist » Записан

Руб. за сто, что Питоньяк
Любит водку и коньяк!
Потому что мне, без оных, -
Не понять его никак...
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!