Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

26 Май 2019, 16:20 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Часто задаваемые вопросы по LibreOffice и Apache OpenOffice.org
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: LibO-3.3.0rs1: старая ошибка установщика  (Прочитано 7670 раз)
0 Пользователей и 1 Гость смотрят эту тему.
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Стартовое сообщение: 6 Декабрь 2010, 22:49 »

LibO-3.3.0rs1_Win_x86. При отказе пользователя от установки расширений, инсталлятор установит их все. Удаление этих расширений штатными средствами ОС или ЛО невозможно.
« Последнее редактирование: 6 Декабрь 2010, 22:51 от ape » Записан
Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #1: 7 Декабрь 2010, 01:19 »

Bug 32150 – Extensions install even when they are unmarked
Записан

ubuntu 12.04 + LibO3.6.0
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #2: 7 Декабрь 2010, 01:46 »

Установка расширений "под замок":
1. Устанавливаем Офис со всеми необходимыми пользователю компонентами. (Если в дальнейшем через Установку и удаление программ произвести модификацию Офиса, то это приведёт и к установке расширений, от которых мы избавляемся.)
2. Используя Проводник, в папке с установленным Офисом открываем \share\prereg\bundled\registry и удаляем из неё всё содержимое.
3. Используя Проводник, в папке с установленным Офисом открываем \share\prereg\bundled и оставляем в ней только файл lastsynchronized.
4. Используя Проводник, в папке с установленным Офисом открываем \share\extensions и оставляем в ней только необходимые нам расширения.
5. Запускаем Офис. (Воможно, что после опроса расширений, soffice.bin работу самостоятельно завершит - не беда, запуск следует повторить.)
6. Используя Менеджер расширений, устанавливаем необходимые ***.oxt.
7. Используя Проводник, в папке с установленным Офисом открываем \share\uno_packages\cache\uno_packages и в папках \***.tmp_ находим установленные нами расширения, которые копируем в любую, созданную вне Офиса, Новую папку.
8. Используя Менеджер расширений, удаляем установленные расширения и перезапускаем Офис.
9. Завершив работу Офиса, из Новой папки премещаем скопированные расширения в \share\extensions и запускаем Офис. (После опроса расширений, soffice.bin работу самостоятельно завершит - запуск следует повторить.) В результате Менеджер расширений покажет примерно следующее ***.png.
Примечание. После установки расширения openclipart-png-ru_0.1.oxt содержимое из \share\uno_packages\cache\uno_packages\**.tmp_\openclipart-png-ru_0.1.oxt\gallery копируется в \Basis\share\gallery; далее расширение удаляется Менеджером расширений и в списке установленных расширений более не отражается.
----------------------------
1. Пока это единственный найденный мною способ "обезопасить" расширения Администратора от "удаленческого" произвола простого Пользователя.
2. Изложенное применимо и к флэш-версии.


[вложение удалено Администратором]
« Последнее редактирование: 7 Декабрь 2010, 07:51 от ape » Записан
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #3: 11 Декабрь 2010, 16:32 »

Не нашёл, где задокументировано:
1. При установке ЛО через Панель управления запуском libreoffice33.msi установка компонентов vcredist_x64.exe и vcredist_x86.exe не производится.
2. При выборе языковых пакетов доступны новые опции (см. ***.png). Однако выбор варианта установки возможен только один раз - при выборе 1-го языка; остальные языковые пакеты его наследуют.

[вложение удалено Администратором]
Записан
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #4: 22 Декабрь 2010, 10:29 »

Устанавливал через Панель управления запуском libreoffice33.msi из предварительно распакованного архива (1-е сообщение темы справедливо и для LibO-3.3.0rs2).
Bug 32150 – Extensions install even when they are unmarked
- исправлено; корректная установка выбранных расширений; LT - не включён в сборку Win_x86_all_lang.
Установка расширений "под замок":
расширения, не включённые в состав пакета LibO-3.3.0rs1 и установленные мной, остались "по месту прописки".
ОШИБКА: во время установки происходит обращение к сайту обновления Оракл.
« Последнее редактирование: 22 Декабрь 2010, 10:34 от ape » Записан
Yakov
Администратор
**
Offline Offline

Сообщений: 2 397


WWW
« Ответ #5: 22 Декабрь 2010, 13:52 »

LT - не включён в сборку Win_x86_all_lang.
Надо бы включить LT-1.1

ОШИБКА: во время установки происходит обращение к сайту обновления Оракл.
Очень странно...
Может быть, установщик проверяет обновления для расширений от Оракла?
Записан

Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #6: 22 Декабрь 2010, 18:33 »

LT - не включён в сборку Win_x86_all_lang
В LibO_3.3.0rc2_Linux_x86_install-deb_en-US.tar.gz и LibO_3.3.0rc2_Win_x86_install_multi.exe тоже нет LT.
Записан

ubuntu 12.04 + LibO3.6.0
Yakov
Администратор
**
Offline Offline

Сообщений: 2 397


WWW
« Ответ #7: 23 Декабрь 2010, 00:09 »

Похоже, там пропали и другие расширения.
Например, нет в rs2   MySQL Connector!
Записан

Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #8: 18 Январь 2011, 13:19 »

Надо бы включить LT-1.1
Есть тема Bug 31059 – A grammar checking in LibreOffice
Записан

ubuntu 12.04 + LibO3.6.0
Yakov
Администратор
**
Offline Offline

Сообщений: 2 397


WWW
« Ответ #9: 18 Январь 2011, 16:29 »

Теперь уже актуальная версия версия 1.2

А если разработчикам LO не нравится то, что LT требует Java,
то можно включить LightProof (но у него гораздо меньше возможностей!) на Python!
Или взять старую версию LT, которая работает на Python (но для неё нет интеграции с OOo и проверка поддерживается только для  английского, немецкого и венгерского языков).

Записан

ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #10: 18 Январь 2011, 17:56 »

Теперь уже актуальная версия версия 1.2
А если разработчикам LO не нравится то, что LT требует Java,
то можно включить LightProof (но у него гораздо меньше возможностей!) на Python!
Или взять старую версию LT, которая работает на Python (но для неё нет интеграции с OOo и проверка поддерживается только для  английского, немецкого и венгерского языков).
ИМХО:
1. У ЛТ нет поддержки всех языков дистрибутива, поэтому нет и в ЛО.
2. Похоже, что у Питона-2.6 проблема с совместимость скриптов предыдущих версий, включая версию 2.4, которую ранее использовали в ООО.
Записан
Yakov
Администратор
**
Offline Offline

Сообщений: 2 397


WWW
« Ответ #11: 18 Январь 2011, 22:10 »

английского, немецкого и венгерского языков).
ИМХО:
1. У ЛТ нет поддержки всех языков дистрибутива, поэтому нет и в ЛО.
Поддержка более 15 языков, но в OOo 3.3  поменяли правила наименования локали, поэтому
локализация интерфейса в LibreOffice 3.3 для LT 1.0 и младше доступна только на английском. В LT 1.1 эта проблема исправлена.
Записан

Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!