Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

24 Октябрь 2019, 02:25 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Вы можете задать вопрос по LibreOffice или Apache OpenOffice  без регистрации, используя форму
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: « 1 2 3 4 5 6 »   Вниз
  Печать  
Автор Тема: Ошибки LibreOffice-3.6.x  (Прочитано 44751 раз)
0 Пользователей и 1 Гость смотрят эту тему.
greenman
Форумчанин
***
Offline Offline

Сообщений: 245


« Ответ #18020: 6 Октябрь 2012, 06:18 »

2. Была ли установлена Ява до установки LibO? jre-6u21 не катит, в логах указывалась u23.
3. Если "да", то как?
2. Могу показать историю обновлений
Код:
[2012-02-06 18:11] upgraded libreoffice-common (3.4.5-1 -> 3.4.5-2)
[2012-04-23 21:33] upgraded libreoffice-common (3.4.5-2 -> 3.5.2-1)
[2012-05-18 18:24] upgraded libreoffice-common (3.5.2-1 -> 3.5.3-1)
[2012-06-02 10:19] upgraded libreoffice-common (3.5.3-1 -> 3.5.4-1)
[2012-06-26 23:58] upgraded libreoffice-common (3.5.4-1 -> 3.5.4-2)
[2012-07-12 19:44] upgraded libreoffice-common (3.5.4-2 -> 3.5.5-1)
[2012-08-22 16:49] upgraded libreoffice-common (3.5.5-1 -> 3.5.6-1)
[2012-09-29 12:50] upgraded libreoffice-common (3.5.6-1 -> 3.6.1-4)
[2012-10-05 20:23] upgraded libreoffice-common (3.6.1-4 -> 3.6.2-1)


[2011-10-21 22:47] upgraded openjdk6 (6.b22_1.10.3-1 -> 6.b22_1.10.4-1)
[2012-01-15 12:03] upgraded openjdk6 (6.b22_1.10.4-1 -> 6.b22_1.10.5-1)
[2012-02-06 18:11] upgraded openjdk6 (6.b22_1.10.5-1 -> 6.b24_1.11-1)
[2012-02-18 11:56] upgraded openjdk6 (6.b24_1.11-1 -> 6.b24_1.11.1-1)
[2012-03-05 21:07] upgraded openjdk6 (6.b24_1.11.1-1 -> 6.b24_1.11.1-2)
[2012-03-08 14:28] upgraded openjdk6 (6.b24_1.11.1-2 -> 6.b24_1.11.1-3)
[2012-05-18 18:26] upgraded openjdk6 (6.b24_1.11.1-3 -> 6.b24_1.11.2-1)
[2012-06-16 13:55] upgraded openjdk6 (6.b24_1.11.2-1 -> 6.b24_1.11.3-1)
[2012-09-03 21:02] upgraded openjdk6 (6.b24_1.11.3-1 -> 6.b24_1.11.4-1)
Т.е. openjdk и  LibO были установлены уже давно. До последнего времени этой проблемы не было. (jre-6u21 просто ложилась в home, т.е. не была установлена).
Опрос на форуме арчлинукса показал, что LibO видит яву-7.

3. Стандартным (для archlinux-a) пакетным менеджером - pacman. Из стандартных реп archlinux-a.

При этом можно заранее, если посмотреть сборочный лог, определить необходимую (6_23-33 или 7_4-7) версию. Если в логе указана 7-я Ява, сборку лучше пропустить
Можно ли из этого сделать вывод, что если LibO собирался на системе с Java 7, то с 6-ой эта сборка работать уже не будет? Если так, то ясно, что надо наезжать на майнтейнеров арча.

В данное время в стандартных репах арча две версии jdk - jdk7-openjdk и openjdk6. Логично предположить, что на машине, где собираются пакеты, установлена свежая.
« Последнее редактирование: 6 Октябрь 2012, 06:41 от greenman » Записан
Страниц: « 1 2 3 4 5 6 »   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!