Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

20 Февраль 2019, 02:39 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Доступно и просто о работе в офисных пакетах
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1 2 »   Вниз
  Печать  
Автор Тема: Как пересобрать LIBREOFFICE с флагом use =java  (Прочитано 1908 раз)
0 Пользователей и 1 Гость смотрят эту тему.
mikekaganski
Мастер
*****
Offline Offline

Пол: Мужской
Расположение: Хабаровск -> Москва
Сообщений: 1 232


« Ответ #47741: 14 Август 2018, 11:59 »

Вы не сообщили версию ЛО. В последних версиях можно (в экспериментальном режиме) создавать embedded-БД на базе Firebird 3, для которой не требуется Java (в версии 6.1 поддержка Firebird должна была выйти из экспериментального в нормальный режим, но в 6.1.0 по непонятным причинам этого не произошло - предположительно (по словам главного разработчика) не везде убрал флаг "экспериментально").

Для работы с "традиционной" embedded-БД на основе HSQLDB действительно требуется Java (как её поставить на Астре, чтобы её увидела ЛО - не знаю).

Кроме того, можно пользоваться внешней БД (в принципе, Вы это и сделали с Вашими файлами dBase) - но при этом никто Вас не ограничивает именно примитивными базами dBase. Вы можете работать, например, с MySQL или любой другой БД. Конечно, в этом случае Вам понадобится иметь сервер БД.
« Последнее редактирование: 14 Август 2018, 12:02 от mikekaganski » Записан

С уважением,
Михаил Каганский
Страниц: 1 2 »   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!