Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

19 Октябрь 2018, 17:05 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Здесь можно поблагодарить участников форума Улыбка
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: Как удалить отрицательные числа с листа?  (Прочитано 482 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Ильдар3000
Участник
**
Offline Offline

Сообщений: 5


« Стартовое сообщение: 24 Май 2018, 17:06 »

Добрый день! Вопрос ко всем. Прошу помочь как удалить отрицательные числа с листа. Особенное если отрицательные числа получились в результате формулы.
Записан
JohnSUN
Капитана в тот день называли на "ты"
Гуру
*******
Offline Offline

Пол: Мужской
Расположение: Киев
Сообщений: 2 593


Помогаю людям и компьютерам понимать друг друга


WWW
« Ответ #1: 24 Май 2018, 17:44 »

Добро пожаловать на форум, Ильдар!
"Удалить" - это "спрятать" или "очистить"?
Если спрятать, то можно просто задать формат для ячеек "без отрицательных значений". Например, код формата
Код:
0,00;;0,00;@
делает именно это - ячейки со значениями меньше нуля выглядят пустыми
А если нужно очистить, то можно так:
Ctrl+H - открыть Найти и заменить, в поле Найти вписать минус, указать, что искать нужно в Значениях (см. картинку), нажать Найти все, нажать две кнопки Закрыть (окно с результатами поиска и само окно поиска). Сейчас все ячейки с отрицательными значениями выделены. Просто нажми Delete или BackSpace.


* Отрицательные долой.png (35.14 Кб, 584x940 - просмотрено 8 раз.)
Записан

Владислав Орлов aka JohnSUN
Благодарить-не зазорно.
Подарить благо создателям офиса, нашему ресурсу, мне
economist
Форумчанин
***
Offline Offline

Сообщений: 927


« Ответ #2: 24 Май 2018, 20:51 »

Ильдар3000 - еще можно сделать так, чтобы САМА формула, скажем,в ячейке D2 - всегда давала или 0 или +. Например, если там формула =B2-C2, то её нужно переписать вот так:

=ЕСЛИ((B2-C2)<0;0;(B2-C2))

И всегда она даст или 0 или +. Если нужен не "0", а "-", то пишите так: =ЕСЛИ((B2-C2)<0;"-";(B2-C2))

Очень важно понимать, что "спрятанный" минус, как в посте #1 - остается минусом, несмотря на то, что выглядит как 0. В этом легко убедится, если сослаться на эту ячейку из другой ячейки, скажем E2, формулой вида =D2 - в ней будет минус,

Из этого следует важный вывод: то что видно в ячейке - не всегда то, что в ней содержится. Это два разных понятия. То что видно - можно изменить не меняя значение в ячейке, с помощью формата ячейки.

Когда мы вводим в пустую ячейку только что созданной книги 25.05.18 или формулу =СЕГОДНЯ() - мы это и увидим, но в ячейке на самом деле хранится не 25.05.18, а число 43245. Это число, прошедшее от "начала времен", начавшееся 118,5 лет назад (30/12/1899 г), когда в той же ячейке было 0.  

PS есть еще один способ спрятать "минусы" - условное форматирование.

Кстати, в финансовой отчетности давно решили минусы превращать в скобки, т.е. -100 = (100). Это и заметнее, и правильнее. Есть даже специальный "Финансовый" формат. Эти () позволяют все(!) финансовые формулы - превратить в "суммирование", т.е. в формулу, в которой ошибиться при всем желании не получится.
Записан

Руб. за сто, что Питоньяк
Любит водку и коньяк!
Потому что мне, без оных, -
Не понять его никак...
Ильдар3000
Участник
**
Offline Offline

Сообщений: 5


« Ответ #3: 25 Май 2018, 14:06 »

Ильдар3000 - еще можно сделать так, чтобы САМА формула, скажем,в ячейке D2 - всегда давала или 0 или +. Например, если там формула =B2-C2, то её нужно переписать вот так:

=ЕСЛИ((B2-C2)<0;0;(B2-C2))

И всегда она даст или 0 или +. Если нужен не "0", а "-", то пишите так: =ЕСЛИ((B2-C2)<0;"-";(B2-C2))

Очень важно понимать, что "спрятанный" минус, как в посте #1 - остается минусом, несмотря на то, что выглядит как 0. В этом легко убедится, если сослаться на эту ячейку из другой ячейки, скажем E2, формулой вида =D2 - в ней будет минус,

Из этого следует важный вывод: то что видно в ячейке - не всегда то, что в ней содержится. Это два разных понятия. То что видно - можно изменить не меняя значение в ячейке, с помощью формата ячейки.

Когда мы вводим в пустую ячейку только что созданной книги 25.05.18 или формулу =СЕГОДНЯ() - мы это и увидим, но в ячейке на самом деле хранится не 25.05.18, а число 43245. Это число, прошедшее от "начала времен", начавшееся 118,5 лет назад (30/12/1899 г), когда в той же ячейке было 0.   

PS есть еще один способ спрятать "минусы" - условное форматирование.

Кстати, в финансовой отчетности давно решили минусы превращать в скобки, т.е. -100 = (100). Это и заметнее, и правильнее. Есть даже специальный "Финансовый" формат. Эти () позволяют все(!) финансовые формулы - превратить в "суммирование", т.е. в формулу, в которой ошибиться при всем желании не получится.

Где взять этот финансовый формат?
« Последнее редактирование: 25 Май 2018, 14:24 от Ильдар3000 » Записан
Bigor
Опытный пользователь
***
Offline Offline

Пол: Мужской
Сообщений: 314


« Ответ #4: 25 Май 2018, 15:19 »

Для отображения можно так
Код:
0,00;(#,##);0,00;#,##
, но считать он такие ячейки все-равно будет как с отрицательными числами
Записан
Ильдар3000
Участник
**
Offline Offline

Сообщений: 5


« Ответ #5: 25 Май 2018, 16:09 »

Спасибо большое, помогло!))
Записан
economist
Форумчанин
***
Offline Offline

Сообщений: 927


« Ответ #6: 25 Май 2018, 16:15 »

Чтобы было как в Балансе и Форме 2 - отрицательное в скобках, без копеек, разделяем триады/разряды - то жмем Ctrl+1 - Категория - Особый - Код формата -  

0 000;(# ###);0 000;# ###
Записан

Руб. за сто, что Питоньяк
Любит водку и коньяк!
Потому что мне, без оных, -
Не понять его никак...
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!