Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

11 Декабрь 2018, 19:10 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Часто задаваемые вопросы по LibreOffice и Apache OpenOffice.org
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: Подсчет выполнения плана  (Прочитано 737 раз)
0 Пользователей и 1 Гость смотрят эту тему.
lufthansa
Форумчанин
***
Offline Offline

Пол: Женский
Расположение: Минск
Сообщений: 50



« Стартовое сообщение: 25 Июль 2018, 14:14 »

У меня очередной вопрос.
В принципе в файле понятнее будет, что я хочу.

Есть диапазон ячеек "План" в штуках и диапазон "Факт" в штуках.
По адресам.
В конце таблицы стоит задача подсчитать количество адресов, где план выполнен, перевыполнен и не выполнен.
Но хотелось бы так чтобы не задействовать доп столбец, а потом счётом считать. Возможно ли?

* для форума планы.ods (66.58 Кб - загружено 7 раз.)
Записан
mikekaganski
Мастер
*****
Offline Offline

Пол: Мужской
Расположение: Хабаровск -> Москва
Сообщений: 1 161


« Ответ #1: 25 Июль 2018, 14:27 »

Для "Не выполнено": =SUMPRODUCT(IFERROR($D$5:$D$15/$C$5:$C$15<1;1))
Для "Выполнено": =SUMPRODUCT(IFERROR($D$5:$D$15/$C$5:$C$15=1;0))
Для "Перевыполнено": =SUMPRODUCT(IFERROR($D$5:$D$15/$C$5:$C$15>1;0))
Записан

С уважением,
Михаил Каганский
JohnSUN
Капитана в тот день называли на "ты"
Гуру
*******
Online Online

Пол: Мужской
Расположение: Киев
Сообщений: 2 633


Помогаю людям и компьютерам понимать друг друга


WWW
« Ответ #2: 25 Июль 2018, 14:47 »

Ну да, SUMPRODUCT - самое то.
Только "Не выполнено", наверное, проще посчитать как количество адресов за вычетом "Выполнено" и "Перевыполнено"
Код:
=COUNTA(B5:B15)-C18-C20
И без деления, похоже, тоже можно выкрутиться - просто колонки сравнивать между собой: для "Перевыполнено" получится
Код:
=SUMPRODUCT(C5:C15<D5:D15)
Для "Выполнено" я наваял
Код:
=SUMPRODUCT(N(C5:C15)>0;N(D5:D15)>0;C5:C15=D5:D15)
но теперь вижу, что твой "Выполнено" получается изящнее
Записан

Владислав Орлов aka JohnSUN
Благодарить-не зазорно.
Подарить благо создателям офиса, нашему ресурсу, мне
mikekaganski
Мастер
*****
Offline Offline

Пол: Мужской
Расположение: Хабаровск -> Москва
Сообщений: 1 161


« Ответ #3: 25 Июль 2018, 14:48 »

Да, верно, и так будет оптимальнее Улыбка
Записан

С уважением,
Михаил Каганский
lufthansa
Форумчанин
***
Offline Offline

Пол: Женский
Расположение: Минск
Сообщений: 50



« Ответ #4: 25 Июль 2018, 15:51 »

И без деления, похоже, тоже можно выкрутитьс

действительно можно! Мое мышление думало про процент выполнения больше/меньше/равно 100. :-)

Слушайте, так я упростила Вашу формулу еще больше,

не выполнено =СУММПРОИЗВ(C5:C15>D5:D15) - и именно так будет лучше, потому что нам не надо считать ячейки где плана не было.
перевыполнено =СУММПРОИЗВ(C5:C1<D5:D15)
выполнено - беру формулу Михаила =СУММПРОИЗВ(ЕСЛИОШИБКА((D5:D15/C5:C15=1);0)).

По логике я попробовала для выполнено =СУММПРОИЗВ(C5:C1=D5:D15), но тогда формула выдает количество И пустых ячеек, а не только равных. Ну они и равные 0)).

Можно было бы и отнять все ячейки - не выполнено - перевыполнено, но тогда попадут ячейки на которые план и не стоял.

Ну и спасибо вам)
« Последнее редактирование: 25 Июль 2018, 15:58 от lufthansa » Записан
JohnSUN
Капитана в тот день называли на "ты"
Гуру
*******
Online Online

Пол: Мужской
Расположение: Киев
Сообщений: 2 633


Помогаю людям и компьютерам понимать друг друга


WWW
« Ответ #5: 25 Июль 2018, 16:08 »

и именно так будет лучше, потому что нам не надо считать ячейки где плана не было
И ты конечно же знал об этом с самого начала, просто забыл об этом сказать и выбросить из примера? Ну, бывает...
Записан

Владислав Орлов aka JohnSUN
Благодарить-не зазорно.
Подарить благо создателям офиса, нашему ресурсу, мне
lufthansa
Форумчанин
***
Offline Offline

Пол: Женский
Расположение: Минск
Сообщений: 50



« Ответ #6: 25 Июль 2018, 16:31 »

И ты конечно же знал об этом с самого начала, просто забыл об этом сказать и выбросить из примера? Ну, бывает...

это я)) и если что, зналА)))
Записан
JohnSUN
Капитана в тот день называли на "ты"
Гуру
*******
Online Online

Пол: Мужской
Расположение: Киев
Сообщений: 2 633


Помогаю людям и компьютерам понимать друг друга


WWW
« Ответ #7: 25 Июль 2018, 16:41 »

Нет, ты конечно же забылА  Смеющийся  Смеющийся  Смеющийся
Прости, пожалуйста  Всё хорошо
Записан

Владислав Орлов aka JohnSUN
Благодарить-не зазорно.
Подарить благо создателям офиса, нашему ресурсу, мне
mikekaganski
Мастер
*****
Offline Offline

Пол: Мужской
Расположение: Хабаровск -> Москва
Сообщений: 1 161


« Ответ #8: 25 Июль 2018, 17:08 »

Слушайте, так я упростила Вашу формулу еще больше,
...

Прекрасно! Улыбка
Записан

С уважением,
Михаил Каганский
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!