Сравнение 2ух таблиц с сохранением зависимости между столбцами

Автор Евгений5244, 21 января 2020, 14:33

0 Пользователи и 1 гость просматривают эту тему.

Евгений5244


Евгений5244

#16
Цитата: Bigor от 21 января 2020, 17:00

К сожалению, нашлась ошибка. Неверно сопоставляет данные из т2 с1 и т1 с2.
На скриншотах примеры




Использую формулы
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$B$400000,ПОИСКПОЗ(СЖПРОБЕЛЫ(D2),$A$1:$A$400000,0),1),"")
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$B$400000,ПОИСКПОЗ(СЖПРОБЕЛЫ(D3),$A$1:$A$400000,0),2),"")

economist

Сервис - Параметры - Calc - Вычисления -
ВКЛ Условия на всю ячейку 
ВКЛ Без подстан знаков и рег выражений
Руб. за сто, что Питоньяк
Любит водку и коньяк!
Потому что мне, без оных, -
Не понять его никак...

Евгений5244

Цитата: economist от 22 января 2020, 11:22
Сервис - Параметры - Calc - Вычисления -
ВКЛ Условия на всю ячейку 
ВКЛ Без подстан знаков и рег выражений

Проблема не ушла.
Значение после vpbx должно совпадать с циферным. Однако, все равно проверил:

Bigor

Т.е. в с1 т1 у вас множество одинаковых данных? Формула ищет первое совпадение с1 т1 с с1 Т2. Если нужно выбирать другое, опишите условия отбора
Поддержать разработчиков LibreOffice можно можно тут, а наш форум вот тут

Евгений5244

Цитата: Bigor от 22 января 2020, 12:18
Т.е. в с1 т1 у вас множество одинаковых данных? Формула ищет первое совпадение с1 т1 с с1 Т2. Если нужно выбирать другое, опишите условия отбора


Данные одинаковы, т.е данные из т1 с1 привязаны к т1 с2, и условие поиска по первому будет работать корректно. По какой то причине в итоговой таблице т3 с2 выводится неверный результат.

В т3 (с1 и с2) должно быть такое же значение как и в т1, только добавлена фильтрация соответствий (поиск НЕ уникальных значений) к т2, фактически
то есть:
Т1
vpbx400034510.mangosip.ru                400034510

Т3
vpbx400034510.mangosip.ru                400034510

Bigor

Я с телефона, но мне кажется, что у вас ошибка в #16, во 2 ой формуле поиск тоже должен идти по d2
Поддержать разработчиков LibreOffice можно можно тут, а наш форум вот тут

Евгений5244

Цитата: Bigor от 22 января 2020, 12:53
Я с телефона, но мне кажется, что у вас ошибка в #16, во 2 ой формуле поиск тоже должен идти по d2

Спасибо за наводку! Нашел проблему. Формула ведется из 1ой стройки, поэтому значения просто уехали на 1 строку.