Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

21 Июль 2017, 19:52 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Часто задаваемые вопросы по LibreOffice и Apache OpenOffice.org
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: Проблемы  (Прочитано 4150 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Yujeen33
Новичок
*
Offline Offline

Сообщений: 5


« Стартовое сообщение: 26 Июнь 2014, 08:26 »

Доброго времени суток. Влпрос такой. при обновлении LO c 4.2 на 4.3 оффис не запускается. Сносил, ставил заново из репозитория LO. В чем может быть проблема? Заранее спасибо. Вылетает следующее сообщение:

Невозможно запустить приложение.
service not supplied: loading component library <file:///usr/lib/libreoffice/program/../program/libexpwraplo.so> failed


* 01.png (18.27 Кб, 489x157 - просмотрено 56 раз.)
Записан
greenman
Постоялец
***
Offline Offline

Сообщений: 226


« Ответ #1: 26 Июнь 2014, 08:50 »

У Вас же линукс? Ставьте пакетным менеджером из репозитария своего дистрибутива. Не факт, что версия с сайта LO встанет на любой дистрибутив.

https://www.libreoffice.org/get-help/system-requirements/

Цитата:
As a general rule, you are recommended to install LibreOffice via the installation methods recommended by your particular Linux distribution (such as the Ubuntu Software Center, in the case of Ubuntu Linux).This is because it is usually the simplest way to obtain an installation that is optimally integrated into your system.
« Последнее редактирование: 26 Июнь 2014, 08:53 от greenman » Записан
Yujeen33
Новичок
*
Offline Offline

Сообщений: 5


« Ответ #2: 26 Июнь 2014, 09:28 »

Спасибо. Это ясно. Но ведь какая то причина должна быть. А Ось стоит Ubuntu 14.04
Записан
greenman
Постоялец
***
Offline Offline

Сообщений: 226


« Ответ #3: 26 Июнь 2014, 10:05 »

Но ведь какая то причина должна быть.
Причина - несоответствие версий библиотек.

Как, кстати, обновляли 4.2 -> 4.3? И как ставили? Пишут, что можно попробовать поставить.
(с русификацией)
« Последнее редактирование: 26 Июнь 2014, 10:14 от greenman » Записан
ape
Ветеран
*****
Offline Offline

Сообщений: 2 450


« Ответ #4: 26 Июнь 2014, 17:07 »

Не факт, что версия с сайта LO встанет на любой дистрибутив.
Как, кстати, обновляли 4.2 -> 4.3? И как ставили? Пишут, что можно попробовать поставить
Факт то, что на Ось ТС (хБунту) одновременно встают и прекрасно работают 2 ванильных ЛибОфиса 4.х. Скорее всего, для установки "Ванильных" на У,Х,К-бунту и Минт надо полностью, включая настройки, удалить Убу-Офис. В Лубунту (она без Убу-Офиса) вообще нет каких-либо проблем с установкой и последующим использованием ванильных ЛибО: в 14.04 у меня прекрасно уживаются и 4.2.х, и 4.3.0.1. В файловом менеджере присутствует предложение, какой версией открыть файл.
Устанавливаю не из репов, а тупо скачав и распаковав необходимые компоненты (help, lang, sdk) в общую папку DEBS, удалив ненужные пакеты (dict-es..):
Код:
sudo -s -H
пароль
mc
вход в папку DEBS
dpkg -i *.deb
« Последнее редактирование: 26 Июнь 2014, 17:12 от ape » Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!