Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

27 Ноябрь 2021, 11:12 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Доступно и просто о работе в офисных пакетах
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1 2 »   Вниз
  Печать  
Автор Тема: LibO-3.3.0rs1_Win_x86: LanguageTool  (Прочитано 13920 раз)
0 Пользователей и 1 Гость смотрят эту тему.
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Стартовое сообщение: 6 Декабрь 2010, 17:03 »

LibO-3.3.0rs1_Win_x86: LanguageTool - установлена "под замок" версия 1.0.0. Ошибка в языке (см. ***.png), отображаемом в окне "Сервис - LanguageTool".
P.S. "Правильное" поведение расширения возвращается при установке LanguageTool - 1.1

[вложение удалено Администратором]
« Последнее редактирование: 6 Декабрь 2010, 17:15 от ape » Записан
Yakov
Администратор
**
Offline Offline

Сообщений: 2 589


WWW
« Ответ #1: 6 Декабрь 2010, 17:25 »

LanguageTool - установлена "под замок" версия 1.0.0
Установлена под замок - имеется в виду менеджер расширений не даст установить версию раньше 1.1?
. "Правильное" поведение расширения возвращается при установке LanguageTool - 1.1
То же касается OOo3.3.0
http://forumooo.ru/index.php/topic,777.0.html

Записан
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #2: 6 Декабрь 2010, 17:53 »

Нет, версия ЛТ-1.0 по-умолчанию включена в дистрибутив, поэтому - "под замком" (удалить можно только вручную из папки extentions).
Записан
Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #3: 6 Декабрь 2010, 18:08 »

Нет, версия ЛТ-1.0 по-умолчанию включена в дистрибутив, поэтому - "под замком" (удалить можно только вручную из папки extentions).
Можно не удалять, просто установите LT 1.1.
Записан

ubuntu 12.04 + LibO3.6.0
Yakov
Администратор
**
Offline Offline

Сообщений: 2 589


WWW
« Ответ #4: 6 Декабрь 2010, 19:14 »

Нет, версия ЛТ-1.0 по-умолчанию включена в дистрибутив, поэтому - "под замком" (удалить можно только вручную из папки extentions).
Очень интересно!
Так нужно запостить баг, что в дистрибутиве необходима версия 1.1. LT.
В версии 1.1 исправлен ещё один баг интеграции с OOo (меню LT должно отображаться только во Writer)
http://www.languagetool.org/download/CHANGES.txt
Записан
Yakov
Администратор
**
Offline Offline

Сообщений: 2 589


WWW
« Ответ #5: 6 Декабрь 2010, 19:19 »

Нет, версия ЛТ-1.0 по-умолчанию включена в дистрибутив, поэтому - "под замком" (удалить можно только вручную из папки extentions).
Или запустив LibreOffice с привилегиями администратора.
Записан
Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #6: 6 Декабрь 2010, 19:24 »

Так нужно запостить баг, что в дистрибутиве необходима версия 1.1. LT.
Users - please update LanguageTool to 1.1
Или запустив LibreOffice с привилегиями администратора.
Нет, нужно менеджером пакетов удалять (в Windows - через установку или удаление программ), но если нужно всего лишь обновить, то можно просто установить LT 1.1 (не имеет значения как user или как shared).
Записан

ubuntu 12.04 + LibO3.6.0
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #7: 6 Декабрь 2010, 21:14 »

Нет, версия ЛТ-1.0 по-умолчанию включена в дистрибутив, поэтому - "под замком" (удалить можно только вручную из папки extentions).
Или запустив LibreOffice с привилегиями администратора.
Ошибаетесь, я, против всяких правил, в Windows не просто "из группы администраторов", а Встроенный_учётный_Администратор и сделать такого в ЛО не могу. (Аналоги: в Ubuntu - 1-й_пользователь; root - в остальных Linux.)
Так нужно запостить баг, что в дистрибутиве необходима версия 1.1. LT.
Users - please update LanguageTool to 1.1
Или запустив LibreOffice с привилегиями администратора.
Нет, нужно менеджером пакетов удалять (в Windows - через установку или удаление программ), но если нужно всего лишь обновить, то можно просто установить LT 1.1 (не имеет значения как user или как shared).
Через Установку и удаление программ Учётный_Админ удалить расширения после установки какого-либо обновления расширений не может. Я установил ЛО со всеми расширениями, обновил ЛТ до 1.1: остальное понятно из скриншота.

[вложение удалено Администратором]
« Последнее редактирование: 6 Декабрь 2010, 21:23 от ape » Записан
Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #8: 6 Декабрь 2010, 21:23 »

Через Установку и удаление программ Учётный_Админ удалить расширения после установки какого-либо обновления расширений не может. Я установил ЛО со всеми расширениями, обновил ЛТ до 1.1: остальное понятно из скриншота.
Нет, видите там не замок, а две фигурки - это значит что это не bundled, а shared расширение. Через установку и удаление программ удаляются только bundled расширения. Когда вы обновили расширение bundled LT 1.0. до LT 1.1, вы просто установили второе расширение, в менеджере расширений показано только одно, которое используется. Поэтому после удаления LT 1.0 через установку-удаление программ, с виду ничего не изменилось, но на самом деле (если LT 1.0. в самом деле было удалено, если недочет с установщиком из beta2 исправили), у вас осталось только одно расширение - shared, котоое вы и видите. Вы на самом деле можете установить 3 раза одно и то же расширение : bundled слой, shared слой и user слой. В менеджере расширений видна только активная версия.
Записан

ubuntu 12.04 + LibO3.6.0
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #9: 6 Декабрь 2010, 21:26 »

Внимательно прочитайте предыдущий пост - ЛТ обновлён до 1.1... Если будете в сети минут через 15 покажу аналогичный скрин с удалённым ЛТ-1.1.
Записан
Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #10: 6 Декабрь 2010, 21:29 »

А если вы теперь, после обновления LT до 1.1, удалите LT 1.1 через менеджер расширений, то какой LT останется? Расширения shared не удаляются через установку-удаление программ, только bundled.
Записан

ubuntu 12.04 + LibO3.6.0
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #11: 6 Декабрь 2010, 21:30 »

Скриншот с "родным" для ЛО-3 расширением ЛТ-1.0.

[вложение удалено Администратором]
Записан
Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #12: 6 Декабрь 2010, 21:34 »

Скриншот с "родным" для ЛО-3 расширением ЛТ-1.0.
Т.е., вы удалили LT 1.1 через менеджер расширений, и остался LT 1.0-bundled? А теперь удалите bundled через установку -удаление, если баг с установщиком исправили, то в менеджере расширений вообще не должно остаться расширения LT.
Записан

ubuntu 12.04 + LibO3.6.0
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #13: 6 Декабрь 2010, 21:39 »

Скриншот с "родным" для ЛО-3 расширением ЛТ-1.0.
Т.е., вы удалили LT 1.1 через менеджер расширений, и остался LT 1.0-bundled? А теперь удалите bundled через установку -удаление, если баг с установщиком исправили, то в менеджере расширений вообще не должно остаться расширения LT.
В посте выше - скриншот после удаления через менеджер расширений. А как он удалил - см. очередной скрин.
P.S. Через "Установку..." - смахнутся, если исправят баг, сразу все "замковые" расширения.

[вложение удалено Администратором]
« Последнее редактирование: 6 Декабрь 2010, 21:41 от ape » Записан
Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #14: 6 Декабрь 2010, 21:45 »

В посте выше - скриншот после удаления через менеджер расширений. А как он удалил - см. очередной скрин.
Т.е., вы удадили LT 1.1 через менеджер расширений, а 1.1 остался? А вы перезапустили офис после удаления LT 1.1?
Записан

ubuntu 12.04 + LibO3.6.0
Страниц: 1 2 »   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!