Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

14 Август 2022, 18:09 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Доступно и просто о работе в офисных пакетах
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: Нужна помощь с libreoffice  (Прочитано 11992 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Fedex1
Участник
**
Offline Offline

Сообщений: 5


« Стартовое сообщение: 24 Май 2013, 12:22 »

Нужна помощь c libreoffice на платной основе.
Стоит на ubuntu x64 without gui. Запущен офис в headless. Проблема возникает при конвертации документа с формулами. Картинки получаются с черным фоном.
Кто может помочь решить эту проблему?
Записан
greenman
Форумчанин
***
Offline Offline

Сообщений: 260


« Ответ #1: 24 Май 2013, 12:40 »

Black image when convert doc to html
Записан
Fedex1
Участник
**
Offline Offline

Сообщений: 5


« Ответ #2: 24 Май 2013, 13:29 »

Пробовал. Работает на x32. На x64 не хочет.
Записан
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #3: 24 Май 2013, 18:53 »

В Убунте используется LibO, но не ванильный. Проблема с формулами устранена в LibO-4.0.4. Попробуйте использовать его. Во всяком случае, в ванильном LibO-4.0.4 на Lubuntu-13.04_х64 такую ошибку не встречал.
« Последнее редактирование: 24 Май 2013, 18:55 от ape » Записан
Fedex1
Участник
**
Offline Offline

Сообщений: 5


« Ответ #4: 24 Май 2013, 23:19 »

Я пробовал ставить пакеты с сайта libreoffice 4.0.3, но выдало ошибку. Я не стал разбираться - подключил репозиторий и установил через apt.
Сейчас скачал 4.1 alpha. Так же не ставится, выдает ошибку в одном пакете:
Код:
Unpacking libobasis4.1-kde-integration (from libobasis4.1-kde-integration_4.1.0.0.alpha1-1_amd64.deb) ...
dpkg: error processing libobasis4.1-kde-integration_4.1.0.0.alpha1-1_amd64.deb (--install):
 trying to overwrite '/opt/libreoffice4.1/program/libkdebe1lo.so', which is also in package libobasis4.1-core01 4.1.0.0.alpha1-1

Подскажите куда копать?
Записан
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #5: 25 Май 2013, 07:37 »

Подскажите куда копать?
1. http://www.lubuntu.ru/forum/viewtopic.php?f=15&t=322&start=10#p5981
2. Дополнительно поясняю:
- распаковываете все пакеты, включая /desktop-integration/.., в одну папку (это изменение п.2);
- из этой папки удаляете DEB-пакеты словарей испанского и французского языков, libobasis4.x-kde-integration..;
- выполняете из этой папки dpkg -i *.deb.
« Последнее редактирование: 25 Май 2013, 07:39 от ape » Записан
Fedex1
Участник
**
Offline Offline

Сообщений: 5


« Ответ #6: 25 Май 2013, 11:42 »

Благодарю за ответ.
В папке /usr/bin /usr/local/bin нет soffice. Т.е. для запускать надо из /opt/libreoffice4.1/program/soffice.bin - это так?
Программа не хочет открывать порт в --headless mode.
В netstat программа присутствует как
unix  2      [ ACC ]     STREAM     LISTENING     183720   /tmp/OSL_PIPE_0_SingleOfficeIPC_6560b2e48bca338e8ba4c6a464b9e42

Чтоб подправить?
Записан
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #7: 25 Май 2013, 11:54 »

Т.е. для запускать надо из /opt/libreoffice4.1/program/soffice.bin - это так?
Да. У меня не было таких заморочек, т.к. в Лубунту LibO нет. "Ванила" всегда встаёт в /opt
Скорее всего, Вы не забыли скинуть в общую установочную папку пакет из последней папочки - deb-menu. Поэтому пакет не установлен. Поиск запуска, как правило, следствие этой ошибки.
--
Я левой ногой (WinNT) в футбол играю, а на правой (NIXы) только хожу.
« Последнее редактирование: 25 Май 2013, 12:05 от ape » Записан
Fedex1
Участник
**
Offline Offline

Сообщений: 5


« Ответ #8: 25 Май 2013, 13:00 »

При распаковке tar -xvf Libreoffice... все распаковывается в одну директорию без поддиректорий.
Через xvfb удалось запустить офиис. Порт виден. Но теперь проблема такого рода образовалась:
Код:
import uno
  File "/opt/libreoffice4.1/program/uno.py", line 21, in <module>
    import pyuno
ImportError: dynamic module does not define init function (initpyuno)

Прописаны такие пути:

Код:
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/opt/libreoffice4.1/ure/bin/:/opt/libreoffice4.1/program"
URE_BOOTSTRAP="vnd.sun.star.pathname:/opt/libreoffice4.1/program/fundamentalrc"
LD_LIBRARY_PATH="/opt/libreoffice4.1/program/"
PYTHONPATH="/opt/libreoffice4.1/program/:/opt/libreoffice4.1/ure-link/lib:/opt/libreoffice4.1/ure-link/bin::/opt/libreoffice4.1/program/"

Записан
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #9: 25 Май 2013, 18:48 »

Я всю распаковку *_deb.tar.gz произвожу с помощью 7zipFM под WinNT. Дебиан-меню - эта папка находится в директории с базовыми пакетами. Возможно, что удаление Убунтофиса проведено некорректно, т.е. не полностью: cудя по Вашему описанию, настройки Убунтофиса в системе присутствуют. Может попробовать снова полностьтью дейнсталлировать (с меню и настройками) LibO и установить по чистому LibO-4.1.0.0beta1?
--
1-я бета уже есть.
« Последнее редактирование: 25 Май 2013, 19:01 от ape » Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!