Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

26 Ноябрь 2020, 00:43 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Вы можете задать вопрос по LibreOffice или Apache OpenOffice без регистрации, используя форму
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1 2 3 4 »   Вниз
  Печать  
Автор Тема: LibreOffice-4.3: ошибки  (Прочитано 31195 раз)
0 Пользователей и 1 Гость смотрят эту тему.
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Стартовое сообщение: 18 Июнь 2014, 18:58 »

@Yakov: будете в случае подтверждения вылета на вставке SVG поддерживать "сепаративный" Windows-bug?
У меня на 32-х и 64-х битовых ХР: Writer, Draw, Impress не создают растр вставляемого SVG, после чего LibO падает!!!
https://bugs.freedesktop.org/show_bug.cgi?id=80198
« Последнее редактирование: 18 Июнь 2014, 19:36 от ape » Записан
Yakov
Администратор
**
Offline Offline

Сообщений: 2 547


WWW
« Ответ #1: 19 Июнь 2014, 07:25 »

Ошибку подтверждаю. Win 7
Записан

ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #2: 22 Июнь 2014, 12:27 »

Регрессия ТОС (FILEOPEN; DOC-ФИЛЬТР) проявилась на известном файле.
Проблема решилась так:
1. Выставил курсор на нижнюю строку текста 1-й страницы.
2. Формат - Абзац - Интервал: Перед абзацем=10см
---
Требуется подтвеждение и версия Офиса, где  "ОК", поэтому прилагаю файл, найденный мною где-то в интернете пару лет тому назад.

* unknown author.doc (182 Кб - загружено 39 раз.)

* capture_001_22062014_134943.png (187.96 Кб, 1567x1048 - просмотрено 90 раз.)
« Последнее редактирование: 22 Июнь 2014, 13:09 от ape » Записан
Yakov
Администратор
**
Offline Offline

Сообщений: 2 547


WWW
« Ответ #3: 22 Июнь 2014, 13:57 »

и версия Офиса, где  "ОК"
4.1.3.2 - всё ОК
Записан

greenman
Форумчанин
***
Offline Offline

Сообщений: 251


« Ответ #4: 22 Июнь 2014, 15:32 »

LibreOffice 4.2.4.2 и 4.2.5.2 - как на левом скриншоте.

LibreOffice 4.1.6.2 - как на правом
« Последнее редактирование: 23 Июнь 2014, 07:13 от greenman » Записан
volkman
Участник
**
Offline Offline

Сообщений: 19


« Ответ #5: 22 Июнь 2014, 21:32 »

4.2.4.2, win7 64 как слева
Записан
rami
Гуру
*******
Offline Offline

Пол: Мужской
Сообщений: 3 029


iMac, LibreOffice и Apache OpenOffice


« Ответ #6: 22 Июнь 2014, 23:14 »

Требуется подтвеждение и версия Офиса, где  "ОК", поэтому прилагаю файл, найденный мною где-то в интернете пару лет тому назад.
LibreOffice 4.3.0.0 и 4.2.4 открыли неправильно, как слева, а Apache OpenOffice 4.1.0 открыл правильно, как справа.
В LibreOffice 4.3.0.0 зашёл в меню "Вставка" потом "Раздел...", добавил 2 Раздел (он не отображался), а потом откатил назад (undo) и всё стало правильно. Сохранил документ и теперь он всё время открывается правильно. Я думаю, что это какая-то "бяка" в документе, а не в LibreOffice.
Записан

ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #7: 23 Июнь 2014, 08:25 »

Я думаю, что это какая-то "бяка" в документе, а не в LibreOffice
Не считаю Ваши мысли правильными:
1. Всё ОК в LibO-4.0.6;4.1.3 - т.е. регрессия налицо.
2. "Бяки" нет. Есть "ТОС + текст + сноски_с_переносом_на_следующую_страницу". С этим LibO перестал справляться, начиная с 4.2.0.1. Последние Офисы, похоже, пытаются разместить последнюю сноску 1-й страницы без переноса на части текста сноски на 2-ю страницу.
--
Нашёл ещё и "стилевую" ошибку.
 ЛибО-4.2.х;4.3.х к стилю "Сноска" добавляют неизвестно откуда взятый "footnote text". При этом именно он соответствует исходному стилю концевых сносок. Ошибка проявляется и при открывании DOCX, созданного из исходного DOC-а. Смена стиля сносок происходит, если сноска начинается с курсива.
« Последнее редактирование: 23 Июнь 2014, 08:27 от ape » Записан
greenman
Форумчанин
***
Offline Offline

Сообщений: 251


« Ответ #8: 23 Июнь 2014, 08:41 »

1. Всё ОК в LibO-4.0.6;4.1.3
Выше я добавил - 4.1.6.2 - OK
Записан
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #9: 24 Июль 2014, 17:22 »

У меня в ХР-64 - нет. При включённой автопроверке - все слова "над красной волной".
У кого-нибудь работает?
--
Английский - не проверял.
Записан
Yakov
Администратор
**
Offline Offline

Сообщений: 2 547


WWW
« Ответ #10: 24 Июль 2014, 18:51 »

У кого-нибудь работает?
Не работает.  Проверка орфографии сбоит.
А вот с установленным сторонним словарём (он у меня автоматом установился с профиля от предыдущей версии)  - работает.
А вот обновлённый LightProof в эту версию ещё не попал...
Записан

Yakov
Администратор
**
Offline Offline

Сообщений: 2 547


WWW
« Ответ #11: 24 Июль 2014, 18:53 »

Английский то же не работает.
Записан

Helen
Администратор
**
Offline Offline

Пол: Женский
Расположение: Екатеринбург
Сообщений: 2 573


WWW
« Ответ #12: 24 Июль 2014, 19:46 »

https://bugs.freedesktop.org/show_bug.cgi?id=81511

Добавлено: похоже, что будет RC4 из-за этого бага.
« Последнее редактирование: 24 Июль 2014, 19:54 от Helen » Записан
Helen
Администратор
**
Offline Offline

Пол: Женский
Расположение: Екатеринбург
Сообщений: 2 573


WWW
« Ответ #13: 28 Июль 2014, 15:45 »

Четвёртый релиз-кандидат доступен для загрузки http://ru.libreoffice.org/download/pre-releases/
Пожалуйста, проверьте, наблюдается ли ошибка с проверкой орфографии/грамматики.
Записан
Yakov
Администратор
**
Offline Offline

Сообщений: 2 547


WWW
« Ответ #14: 28 Июль 2014, 20:30 »

Проверка работает нормально.
Записан

Страниц: 1 2 3 4 »   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!