Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

26 Ноябрь 2020, 01:19 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Здесь можно поблагодарить участников форума Улыбка
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: Ошибка в LibreOffice 4.4.1  (Прочитано 11409 раз)
0 Пользователей и 1 Гость смотрят эту тему.
CryModeOn
Участник
**
Offline Offline

Сообщений: 5


« Стартовое сообщение: 1 Март 2015, 21:35 »

Доброго дня! Поставил обнову 4.4.1, после закрытия документа в Calc стала выпрыгивать ошибка DDE server windows: soffice.bin... До этого никогда не было, windows xp sp3 стоит. До этой обновы все было прекрасно. Не подскажете из за чего может такое быть или будет ли исправлен баг в следующей версии?
Записан
kompilainenn
Мастер
*****
Offline Offline

Сообщений: 3 092



« Ответ #1: 1 Март 2015, 21:45 »

пишите в багзиллу
Записан

Поддержать разработчиков LibreOffice можно тут, а наш форум вот тут
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #2: 1 Март 2015, 22:01 »

стала выпрыгивать ошибка DDE server windows: soffice.bin...
Одной из причин такой ошибки может быть несоответствие версии (или отсутствие) библиотек MS_VC++, той которая использовалась при компиляции установочного пакета. Например, в моей 64-битовой ОС используется Мастер-релиз 64-битового Либре Офиса, а MS_VC++_2013 (х64) установлен не был. Завершение работы Офиса каждый раз сопровождалось таким же, как у Вас, сообщением. После установки недостающих 64-битовых библиотек сообщения от ОС прекратились.
---
Библиотеки msvcp110.dll и msvcp110.dll (для сборки используется MS_VC++_2012_х86) должны иметь версию 11.0.51106.1
« Последнее редактирование: 1 Март 2015, 22:11 от ape » Записан
CryModeOn
Участник
**
Offline Offline

Сообщений: 5


« Ответ #3: 2 Март 2015, 10:33 »

стала выпрыгивать ошибка DDE server windows: soffice.bin...
Одной из причин такой ошибки может быть несоответствие версии (или отсутствие) библиотек MS_VC++, той которая использовалась при компиляции установочного пакета. Например, в моей 64-битовой ОС используется Мастер-релиз 64-битового Либре Офиса, а MS_VC++_2013 (х64) установлен не был. Завершение работы Офиса каждый раз сопровождалось таким же, как у Вас, сообщением. После установки недостающих 64-битовых библиотек сообщения от ОС прекратились.
---
Библиотеки msvcp110.dll и msvcp110.dll (для сборки используется MS_VC++_2012_х86) должны иметь версию 11.0.51106.1

Спасибо за совет! Получается, в версии 4.4.0 эти библиотеки еще не использовались? Наверно, поставлю обратно 4.4.0 и буду ждать 4.5.0, чтоб стабильно все было. И вообще, не очень нравится, что для работы свободного софта все таки нужны МС библиотеки)
Записан
kompilainenn
Мастер
*****
Offline Offline

Сообщений: 3 092



« Ответ #4: 2 Март 2015, 11:01 »

И вообще, не очень нравится, что для работы свободного софта все таки нужны МС библиотеки)
тут проблема в том, что сборочная среда под виндовс - это визал студио от самой МС, в которой зависимостями и тянутся либы от МС.
Записан

Поддержать разработчиков LibreOffice можно тут, а наш форум вот тут
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #5: 2 Март 2015, 13:09 »

1. Получается, в версии 4.4.0 эти библиотеки еще не использовались?
2. Наверно, поставлю обратно 4.4.0 и буду ждать 4.5.0, чтоб стабильно все было.
1. LibO-4.4.0 собиралась в сборочной среде MS_VC++_2012_х86 версии 11.0.51106.1.
    Какая версия используется в 4.4.1 можно определить, если в папке C:\Program Files\LibreOffice 4\program\shlxthdl\.. посмотреть свойства (версию) любого из файлов - msvcp110.dll или msvcp110.dll. Можете сравнить соответствие версий, посмотрев версию библиотек в C:\WINDOWS\system32\msvcp110.dll,msvcp110.dll. Возможно, что у Вас в этом адресе установлен обновлённый пакет MS_VC++_2012_х86 версии 11.0.60610.1 (это - 3-й апдейт пакета). Если версии библиотек разные, то можно поступить так:
- создать резервную копию в виде архива файлов C:\Program Files\LibreOffice 4\program\shlxthdl\msvcp110.dll,msvcp110.dll
- скопировать файлы C:\Program Files\LibreOffice 4\program\shlxthdl\msvcp110.dll,msvcp110.dll в C:\WINDOWS\system32\.. , согласившись с заменой файлов
- на всякий случай (т.к. у Вас 32-битовый ХРюша), я из C:\Program Files\LibreOffice 4\program\shlxthdl\.. (т.е. там, где библиотеки) удалил ненужные Вашей ОС две 64-битных библиотеки - ooofilt_x64.dll и shlxthdl_x64.dll - которые (т.к. ЛО-4.4.х - 32-битовый) необходимы только для Проводника и ActiveX 64-битовых Windows.
--
2. Ни в коем случае нельзя возвращаться на 4.4.0 - там ошибок ещё больше. Я, например, не собирался устанавливать 4.4.х ранее 4.4.2. Но, видимо, поставлю-таки 4.4.1.2, чтобы посмотреть Вашу проблему.
« Последнее редактирование: 2 Март 2015, 13:17 от ape » Записан
CryModeOn
Участник
**
Offline Offline

Сообщений: 5


« Ответ #6: 2 Март 2015, 13:25 »

1. Получается, в версии 4.4.0 эти библиотеки еще не использовались?
2. Наверно, поставлю обратно 4.4.0 и буду ждать 4.5.0, чтоб стабильно все было.
1. LibO-4.4.0 собиралась в сборочной среде MS_VC++_2012_х86 версии 11.0.51106.1.
    Какая версия используется в 4.4.1 можно определить, если в папке C:\Program Files\LibreOffice 4\program\shlxthdl\.. посмотреть свойства (версию) любого из файлов - msvcp110.dll или msvcp110.dll. Можете сравнить соответствие версий, посмотрев версию библиотек в C:\WINDOWS\system32\msvcp110.dll,msvcp110.dll. Возможно, что у Вас в этом адресе установлен обновлённый пакет MS_VC++_2012_х86 версии 11.0.60610.1 (это - 3-й апдейт пакета). Если версии библиотек разные, то можно поступить так:
- создать резервную копию в виде архива файлов C:\Program Files\LibreOffice 4\program\shlxthdl\msvcp110.dll,msvcp110.dll
- скопировать файлы C:\Program Files\LibreOffice 4\program\shlxthdl\msvcp110.dll,msvcp110.dll в C:\WINDOWS\system32\.. , согласившись с заменой файлов
- на всякий случай (т.к. у Вас 32-битовый ХРюша), я из C:\Program Files\LibreOffice 4\program\shlxthdl\.. (т.е. там, где библиотеки) удалил ненужные Вашей ОС две 64-битных библиотеки - ooofilt_x64.dll и shlxthdl_x64.dll - которые (т.к. ЛО-4.4.х - 32-битовый) необходимы только для Проводника и ActiveX 64-битовых Windows.
--
2. Ни в коем случае нельзя возвращаться на 4.4.0 - там ошибок ещё больше. Я, например, не собирался устанавливать 4.4.х ранее 4.4.2. Но, видимо, поставлю-таки 4.4.1.2, чтобы посмотреть Вашу проблему.


Спасибо огромное, как буду дома попробую исправить по Вашему алгоритму. Но, все таки надеюсь, что в последующих версиях такой неприятности не будет. Кстати, как я понял, она никак не мешает работе с файлами, ошибка выскакивает уже после закрытия сохраненного (или нет) файла.
Записан
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #7: 2 Март 2015, 13:40 »

Спасибо огромное, как буду дома попробую исправить по Вашему алгоритму. Но, все таки надеюсь, что в последующих версиях такой неприятности не будет. Кстати, как я понял, она никак не мешает работе с файлами, ошибка выскакивает уже после закрытия сохраненного (или нет) файла.
Всё так. Из истории - очень схожая ситуация была с ЛО-3.6.х
Записан
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #8: 2 Март 2015, 18:31 »

Установил ЛО-4.4.1 в Windows XPsp3 (32-бит). Библиотеки MS_VC++_2012_х86 (msvcp110.dll и msvcp110.dll) в LibreOffice 4\program\shlxthdl\.. отсутствуют. Скорее всего - это особенность установки Офиса в 32-битовые Окна. Предполагаю, что у Вашей ОС не установлен vcredist_x86.exe (MS_VC++_2012_х86). Поэтому при завершении работы Офиса Вы и получали сообщения от операционной системы.
Есть 2 выхода:
1. Скачать прилагаемый архив и положить файлы, содержащиеся в нём, в LibreOffice 4\program\shlxthdl\..
2. Если п.1 не помог, то скачайте vcredist_x86.exe отсюда: http://www.microsoft.com/ru-ru/download/details.aspx?id=30679&134b2bb0-86c1-fe9f-d523-281faef41695=1&fa43d42b-25b5-4a42-fe9b-1634f450f5ee=True и установите пакет в операционную систему.

* ms_vc_2012.zip (573.28 Кб - загружено 67 раз.)
« Последнее редактирование: 2 Март 2015, 18:36 от ape » Записан
CryModeOn
Участник
**
Offline Offline

Сообщений: 5


« Ответ #9: 2 Март 2015, 21:04 »

Скачал, но пока думаю не ставить. Хочу дождаться следующей версии, если ошибка останется то поставлю этот пакет. Плохо, что ЛО не ставит те зависимости, которые нужны для его полноценной работы автоматом.
Записан
CryModeOn
Участник
**
Offline Offline

Сообщений: 5


« Ответ #10: 2 Март 2015, 21:05 »

И, да, у меня такого пакет ВС не установлено, самый последний 2010. Но, тогда назревает вопрос, почему раньше то все работало нормально...
Записан
ape
Форумчанин
***
Offline Offline

Сообщений: 2 468


« Ответ #11: 3 Март 2015, 10:26 »

Получил неожиданный результат.   Да уж...
Сообщения об ошибке от ХРюши не получаю только в том случае, если завершаю работу ЛО из Центра запуска приложений. Причина мне не понятна. Писать в Багзиллу смысла нет - ошибка получит статус нормальной (или минорной) и нуждающейся в информации, после чего "утонет".
Думаю, что всё исправится само-собой. Так, например, случилось с редерингом SVG-изображений, наконец-таки вернувшимся к отображению всех элементов, как было в ЛО-3.6.7.
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!