Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

22 Сентябрь 2019, 09:17 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Вы можете задать вопрос по LibreOffice или Apache OpenOffice  без регистрации, используя форму
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: « 1 2   Вниз
  Печать  
Автор Тема: объединить несколько файлов, а именно свод года  (Прочитано 4597 раз)
0 Пользователей и 1 Гость смотрят эту тему.
economist
Форумчанин
***
Offline Offline

Сообщений: 984


« Ответ #15: 21 Ноябрь 2016, 08:30 »

Calc не даст и половины ощущения от Excel в плане работы со ссылками книг и их автопереименованием.
Ситуацию отчасти исправят именованные диапазоны, но скорее всего таблица станет
тошнотворно медленной уже к концу первого года.

Могу предложить еще одно изящное решение - назовем его условно "Секция итогов".

Вверху таблицы 20 строк зарезервированы под "итоговые строки", которые сами перевычисляются по мере ввода данных. Листы по проектам и подразделениями не поделены, вместо этого просто включается на этом же ОДНОМ листе - Автофильтр, причем есть удобная колонка для отбора фильтра сразу по 2-м критериями одновременно - "Подразделение_Объект". Секция итогов выглядит так:

Байкодром "Космодур" ИТОГО - след. ячейка - =СУММЕСЛИ(B22:B1000000;"Космодур";E22:E1000000)
Аэродром "Писецк" ИТОГО - след. ячейка - =СУММЕСЛИ(B22:B1000000;"Писецк";E22:E1000000)
Летное поле "Канавырыл"  - след. ячейка - =СУММЕСЛИ(B22:B1000000;"Хьюстон! У Нас Проблемы";E22:E1000000)
итд 20 строк

А секция ввода данных - вот так (с 21-й строки)

№ - Объект - Подразделение - Сумма - Оператор
1 - Писецк - Косари - 10000 - Берлага
2 - Канавырыл - Копари - 100000 - Берлага
...

В отличие от всевозможных "нычек", отдельных листов итп - ведение "проводок" на одном листе десятикратно уменьшит ошибки из-за пересортицы и 5-кратно облегчит ввод.

Секцию итогов нужно закрепить областями, чтобы она не прокручивалась, можно дополнить аналитикой, процентом готовности, суммой плановой сметы итп. Сделать няшку, в общем.

Calc позволяет вводить данные в один документом нескольким людям в ту же секунду. При вводе новой строки может возникнуть конфликт, но это лечится десятком простых способов, простейший из которых - "заготовки" строк. Предположим я из "Косарей", ввожу свои работы, Для этого включил фильтр, скопировал автозаполнением 10 строк "на сегодня", сохранил. Всё - теперь эти строки никто кроме меня не займет, т.к. фильтр их скроет. Таким образом можно в 1 файл получать данные одновременно от 3-7 операторов одномоментно, без каких-либо артефактов.  
« Последнее редактирование: 21 Ноябрь 2016, 08:35 от economist » Записан

Руб. за сто, что Питоньяк
Любит водку и коньяк!
Потому что мне, без оных, -
Не понять его никак...
rami
Гуру
*******
Online Online

Пол: Мужской
Сообщений: 2 764


MacBook Pro, LibreOffice и Apache OpenOffice


« Ответ #16: 21 Ноябрь 2016, 09:14 »

А пересчёт формул при загрузке у вас включен? Если нет, то даже обновление ссылок не поможет.


* Пересчёт формул.png (108.73 Кб, 890x432 - просмотрено 13 раз.)
Записан

Vala
Участник
**
Offline Offline

Сообщений: 8


« Ответ #17: 25 Ноябрь 2016, 08:17 »

вернулись к Excel. сожалею, что не смогли настроится
Записан
mikekaganski
Мастер
*****
Offline Offline

Пол: Мужской
Расположение: Хабаровск -> Москва
Сообщений: 1 469


« Ответ #18: 25 Ноябрь 2016, 10:16 »

Немного не понял, что вызвало затруднения.
Был предложен вариант с копированием листа при условии абсолютных ссылок на исходном листе.
Имеется вариант, когда выделается нужный диапазон (или весь лист) и вставляется специальной вставкой - ссылкой (тогда, также как и в первом случае, получается внешняя ссылка, которая обновляется при открытии или при обновлении вручную)
Имеется вариант использования функции DDE - тогда обновление происходит на лету (для работы с диапазоном нужно использовать формулу массива).

Было бы интересно хотя бы получить описание того, что оказалось неосуществимо.
Записан

С уважением,
Михаил Каганский
Страниц: « 1 2   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!