Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

23 Апрель 2019, 05:52 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Доступно и просто о работе в офисных пакетах
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: Счёт непустых значений ячеек с отбрасыванием пустых формул  (Прочитано 774 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Zomgmeister
Участник
**
Offline Offline

Сообщений: 10


« Стартовое сообщение: 15 Май 2018, 17:23 »

Здравствуйте!

Вопрос наверняка с простым ответом.

Имеется диапазон для счёта, в котором могут быть значения произвольных типов. Фактически — числа и текст, но это ладно. И мне нужно сосчитать число непустых ячеек в этом диапазоне.

Однако «СЧЁТА» не подходит, так как на самом деле все ячейки диапазона непустые. В них формулы, которые могут показывать либо ничего (""), либо значение, которое нужно считать. Буквально: C2=ЕСЛИ(A2=1;B2;""). Вот диапазон Cx1:Cx2 мне и нужен, и считаться в нём должны все ячейки, в которых показано что-либо.

Как быть? Предполагаю, что здесь нужно как-то работать от «СЧЁТЕСЛИ», но не пойму, как именно.

Образец во вложении.

* счёт.ods (11.36 Кб - загружено 7 раз.)
Записан
Zomgmeister
Участник
**
Offline Offline

Сообщений: 10


« Ответ #1: 15 Май 2018, 17:34 »

О, нагуглил Улыбка Удалять свои не могу, но вдруг кому-то ещё понадобится: =СЧЁТЕСЛИ(C2:C8;"<>"&"")

Извините за бессмысленное сообщение!
Записан
kokosergei
Участник
**
Offline Offline

Сообщений: 9


« Ответ #2: 1 Апрель 2019, 22:37 »

Приго
О, нагуглил Улыбка Удалять свои не могу, но вдруг кому-то ещё понадобится: =СЧЁТЕСЛИ(C2:C8;"<>"&"")

Извините за бессмысленное сообщение!

Очень пригодилось! СПАСИБО!
Записан
OOKapitan
Форумчанин
***
Offline Offline

Сообщений: 453


« Ответ #3: 3 Апрель 2019, 12:31 »

Можно скопировать столбец --> в соседнем столбце нажать "Вставить как" --> ставим галочки только напротив полей: "Текст", "Дата", "Число", жмём "ОК" и уже по этому столбцу ищем непустые ячейки.
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!