Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

16 Июль 2019, 01:44 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Здесь можно поблагодарить участников форума Улыбка
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: Проблема с логической функцией "ЕСЛИ". (Ошибка: 508)  (Прочитано 577 раз)
0 Пользователей и 1 Гость смотрят эту тему.
leonidlucko
Я зелёный. Как логотип ms excel.
Участник
**
Offline Offline

Пол: Мужской
Расположение: Zelenograd
Сообщений: 5



« Стартовое сообщение: 29 Апрель 2019, 13:08 »

Здравствуйте, уважаемые форумчане! Я учусь в 8 классе и при выполнении задания по информатике у меня появились трудности, помогите пожалуйста!
Задание: Ученики перед поступлением в гимназию сдают математику, русский и английский языки. Проходной балл – 12. По математике для поступления нужно получить не менее 4 баллов. Составить отчет о поступлении. Исходные данные см вложение.
Когда я посчитал в отдельном столбце сумму баллов и принялся составлять отчёт о поступлении, в мастере функций произошла ошибка 508 (см вложение). Покурив мануалы, я узнал что эта ошибка появляется когда отсутствует скобка: например, есть закрывающие скобки, но нет открывающих скобок. Но проверив скобки, я понял что всё на месте! Помогите, пожалуйста, Д/з надо срочно сдать, но эта ошибка всё портит!  В замешательстве  Плачущий
 


* Снимок экрана от 2019-04-29 12-50-56.png (229.73 Кб, 1366x768 - просмотрено 23 раз.)
Записан
rami
Гуру
*******
Offline Offline

Пол: Мужской
Сообщений: 2 733


MacBook Pro, LibreOffice и Apache OpenOffice


« Ответ #1: 29 Апрель 2019, 13:15 »

Слова "Поступил" и "Не поступил" в формуле  должны быть в кавычках.
Записан

mikekaganski
Мастер
*****
Online Online

Пол: Мужской
Расположение: Хабаровск -> Москва
Сообщений: 1 416


« Ответ #2: 29 Апрель 2019, 13:18 »

Ну, и решение нужно додумать: те, кто набрал больше 12 баллов, не попадут в гимназию, бедняжки; а те, кто получил пятёрки по русскому и английскому, но двойку по математике, прекрасно пройдут.
Записан

С уважением,
Михаил Каганский
leonidlucko
Я зелёный. Как логотип ms excel.
Участник
**
Offline Offline

Пол: Мужской
Расположение: Zelenograd
Сообщений: 5



« Ответ #3: 29 Апрель 2019, 14:08 »

Слова "Поступил" и "Не поступил" в формуле  должны быть в кавычках.
Спасибо, большое! Я без вашей помощи не справился бы!  Всё хорошо
Записан
leonidlucko
Я зелёный. Как логотип ms excel.
Участник
**
Offline Offline

Пол: Мужской
Расположение: Zelenograd
Сообщений: 5



« Ответ #4: 29 Апрель 2019, 14:14 »

Ну, и решение нужно додумать: те, кто набрал больше 12 баллов, не попадут в гимназию, бедняжки; а те, кто получил пятёрки по русскому и английскому, но двойку по математике, прекрасно пройдут.
Спасибо вы правы, когда я составлял формулу я об этом тоже думал, но решил попробовать хотя бы так. В итоге моя формула выглядит так: =ЕСЛИ(E3<12;"не поступил";ЕСЛИ(B3>=4;"поступил";"не поступил")) В общем, Иванов - горе-математик не поступил!  Смеющийся


* Снимок экрана от 2019-04-29 14-11-52.png (58.97 Кб, 725x397 - просмотрено 13 раз.)
Записан
mikekaganski
Мастер
*****
Online Online

Пол: Мужской
Расположение: Хабаровск -> Москва
Сообщений: 1 416


« Ответ #5: 29 Апрель 2019, 14:19 »

Очхор.

Это можно упростить:
Код:
=ЕСЛИ(И(E3>=12;B3>=4);"поступил";"не поступил")
Записан

С уважением,
Михаил Каганский
leonidlucko
Я зелёный. Как логотип ms excel.
Участник
**
Offline Offline

Пол: Мужской
Расположение: Zelenograd
Сообщений: 5



« Ответ #6: 3 Май 2019, 18:43 »

Очхор.

Это можно упростить:
Код:
=ЕСЛИ(И(E3>=12;B3>=4);"поступил";"не поступил")
Спасибо, я уже отправил, но буду знать!  Azn
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!