Автозаполнение столбцов с привязкой к выпадающим спискам

Автор Barmalei1802, 16 сентября 2022, 15:07

0 Пользователи и 1 гость просматривают эту тему.

Barmalei1802

Здравия Всем!!!
Прочитал большую часть форума Calc ответа не нашел, но сразу извиняюсь если это дублирование какой-то темы.
Есть выпадающий список (Мужчины; Женщины), как к этим спискам привязать нормы.
Выбрал из списка Мужчины, в перечне анализов референтные значения встали для мужчин, если женщины, то соответственно женские нормы.
Надеюсь не очень сумбурно объяснил. Не могу сформулировать по другому.
Заранее, всем спасибо!

Bigor

#1
Добрый день.

Формула в J7 и протянуть вниз
=INDEX('М Ж'.$B$3:$C$6;ROW(A1);MATCH($C$1;'М Ж'.$B$2:$C$2;0))или
=ИНДЕКС('М Ж'.$B$3:$C$6;СТРОКА(A1);ПОИСКПОЗ($C$1;'М Ж'.$B$2:$C$2;0))
так короче =HLOOKUP($C$1;'М Ж'.$B$2:$C$6;ROW(C2);0)
Поддержать разработчиков LibreOffice можно можно тут, а наш форум вот тут

Barmalei1802

#2
Огромное спасибо. Цены вам нет. :beer:
А еще вопрос созрел. А можно как-то настроить наследование условного форматирования? То есть, если в одном листе у меня прописан расчет данных и в результатах вычисления настроено условное форматирование, можно ли его перенести на титульный лист с сохранением услСуточная моча доработка1.xlsx овного форматирования.

economist

Вернуть на другой лист значения с их же УФ можно с помощью Связи с диапазоном: Лист - Связь с...

Если в окне не появляются Диапазоны - надо "перевыбрать" этот же файл через кнопку Обзор.

Для обновления (варианты):
- Флаг Обновлять каждые... 60 сек при вставке связи
- Переоткрыть
- Файл-Перезагрузить
- Макрос (в т.ч. с автозапуском)
- Правка-Ссылки...-Обновить

Поддерживаются как Имена, так и Диапазоны (в Calc два вида имен). Пример - во вложении. Связь создавал на диске D: возможно ее придется переопределить.

Excel так не умеет, он умеет "графически" зеркалировать ячейки с другого листа, внешний рез-т - тот же. Т.е. вы можете в Calc/Excel показывать в любом листе ячейки с форматами и УФ из другого листа и книги, в т.ч. доступной по HTTP/FTP/WEBDAV-протоколам, при соблюдении некоторых правил. 
Руб. за сто, что Питоньяк
Любит водку и коньяк!
Потому что мне, без оных, -
Не понять его никак...