Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

8 Август 2020, 04:11 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Вы можете задать вопрос по LibreOffice или Apache OpenOffice без регистрации, используя форму
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: ALT Linux: не проигрываются mp3 файлы  (Прочитано 7990 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Helen
Администратор
**
Offline Offline

Пол: Женский
Расположение: Екатеринбург
Сообщений: 2 573


WWW
« Стартовое сообщение: 14 Декабрь 2010, 07:39 »

Вопрос из почты:
Добрый день. У меня установлен ALT Linux 5.0, но проблема в том, что в Impress не проигрываются mp3 файлы. Медиаплейер вроде бы что-то воспроизводит (ползунок времени ползет), а звука нет.
В интернете в одном из форумов: http://wiki.services.openoffice.org/wiki/Talk:Impress:_%D0%A7%D0%B0%D1%81%D1%82%D0%BE_%D0%B7%D0%B0%D0%B4%D0%B0%D0%B2%D0%B0%D0%B5%D0%BC%D1%8B%D0%B5_%D0%B2%D0%BE%D0%BF%D1%80%D0%BE%D1%81%D1%8B
gstreamer, как было указано, я установил - звук не появился.
Вы писали, что после установки JMF у вас начал воспроизводиться звук.
Подскажите, как это сделать, а то я скачал сам файл jmf-2_1_1e-linux-i586.bin
, а что дальше с ним делать не знаю. :-(
Я в линуксе почти ничего не понимаю.

Записан
prof-alex
Форумчанин
***
Offline Offline

Пол: Мужской
Сообщений: 354


« Ответ #1: 14 Декабрь 2010, 08:09 »

Там не столько gstreamer нужен, сколько возможность его донастроить. Однако, если не играет только mp3, значит в пакетах у Альта поддержка mp3 вынесена отдельно. У меня gstreamer может проигрывать mp3 либо через media-plugins/gst-plugins-lame, либо media-plugins/gst-plugins-mad.
У нас Yakov по Альту спец.
Записан


«Студентов, ранее изучавших Бейсик, практически невозможно обучить хорошему программированию. Как потенциальные программисты они подверглись необратимой умственной деградации» Э. Дейкстра
Yakov
Администратор
**
Offline Offline

Сообщений: 2 543


WWW
« Ответ #2: 14 Декабрь 2010, 10:43 »

Оптимальным вариантом было установить jmf в виде rpm пакета
(раньше он был в Сизифе, но сейчас я его не нашёл)
Если нет rpm пакета - придётся устанавливать jmf-2_1_1e-linux-i586.bin
Файл jmf-2_1_1e-linux-i586.bin надо запустить на выполнение (необходимо убедиться что в правах файла  установлено свойство ""выполнение", иначе появится ошибка "в доступе отказано")
Далее, после установки jmf, необходимо прописать к нему путь класса в OpenOffice.org (см, скриншот)

[вложение удалено Администратором]
« Последнее редактирование: 14 Декабрь 2010, 10:47 от Yakov » Записан

Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #3: 14 Декабрь 2010, 12:01 »

Если установлена сборка из репозитория, то звук должен проигрываться через gstreamer - и тогда, возможно, не хватает нужного кодека. А если это сборка c сайта openoffice.org, то звук (тоже через gstreamer), там появится только в 3.4 (в текущих испытательных сборках он уже есть начиная с версии dev300m86), а c 3.3.0 и ниже можно использовать jmf.
Записан

ubuntu 12.04 + LibO3.6.0
nsn65
Новичок
*
Offline Offline

Сообщений: 1


« Ответ #4: 14 Декабрь 2010, 17:22 »

добрый день. Спасибо уважаемой Helen, за то что она перенесла мой вопрос на этот форум. У меня версия
OpenOffice.org 3.2.1
OOO320m19 (Build:9505)
которая шла в дистрибутиве ALTLinux. Значит всётаки нужно ставить JMF. Ну тогда помогайте, как это сделать: я скачал его с официального сайта, расширение файла .bin поменял права на файл, при установке он дал прочитать лицензию, спросил, согласен ли я с ней, я подтвердил и он вывалился с ошибкой, что нет такой директории и дальше выдал какие-то кракозябры. Как его (JMF) всётаки ставить?
Записан
convas
Форумчанин
***
Offline Offline

Сообщений: 310


« Ответ #5: 14 Декабрь 2010, 18:27 »

Вот тут что-то похожее про установку jmf:
http://unixforum.org/index.php?showtopic=58604
« Последнее редактирование: 14 Декабрь 2010, 18:30 от convas » Записан
Yakov
Администратор
**
Offline Offline

Сообщений: 2 543


WWW
« Ответ #6: 18 Декабрь 2010, 09:59 »

Оптимальным вариантом было установить jmf в виде rpm пакета
(раньше он был в Сизифе, но сейчас я его не нашёл)
Для ветки 4.1 rpm - пакет
http://sisyphus.ru/ru/srpm/Branch41/jmf/get
Записан

Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!