Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

20 Июль 2019, 02:51 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Здесь можно поблагодарить участников форума Улыбка
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1 2 3 4 »   Вниз
  Печать  
Автор Тема: Формула массива для подсчета суммы  (Прочитано 19244 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Leojse
Участник
**
Offline Offline

Сообщений: 12


« Стартовое сообщение: 10 Февраль 2013, 20:09 »

Добрый вечер.
В файле есть формула массива, которая складывает соответственно числа, разделенные знаком "/" (не деление). То есть, в ячейке А1: 2/300, в ячейке B1: 3/200. По идее, в С1 должен быть результат "5/500". В excel формула работает отлично, открыл в calc, а там в С1 "0/0". Форматы менял, числа другие писал, всё равно не складывает как надо (либо 0/0, либо "ЗНАЧЕН").
Помогите разобраться, почему в calc формула не считается?

[вложение удалено Администратором]
Записан
Yakov
Администратор
**
Offline Offline

Сообщений: 2 411


WWW
« Ответ #1: 10 Февраль 2013, 22:11 »

в таблице используется формула
Код:
{=SUM(--MID(A1:A10;1;SEARCH("/";A1:A10)-1))&"/"&SUM(--MID(A1:A10;SEARCH("/";A1:A10)+1;300))}
Ошибка возникает на этапе SEARCH("/";A1:A10), так как указан диапазон A1:A10
Надо иначе записать формулу
Записан

Leojse
Участник
**
Offline Offline

Сообщений: 12


« Ответ #2: 10 Февраль 2013, 22:16 »

Yakov, подскажите, а как еще можно указать диапазон?
Записан
Hasim
Форумчанин
***
Offline Offline

Сообщений: 754


Woe from wit


« Ответ #3: 11 Февраль 2013, 00:10 »

Правильная формула
Цитата:
{=SUM(VALUE(MID(A1:B1;1;SEARCH("/";A1:B1;1)-1)))&"/"&SUM(VALUE(MID(A1:B1;SEARCH("/";A1:B1;1)+1;LEN(A1:B1)-SEARCH("/";A1:B1;1)+1)))}

Ещё более правильная формула
Цитата:
{=TEXT(SUM(VALUE(MID(A1:B1;1;SEARCH("/";A1:B1;1)-1)));"###")&"/"&TEXT(SUM(VALUE(MID(A1:B1;SEARCH("/";A1:B1;1)+1;LEN(A1:B1)-SEARCH("/";A1:B1;1)+1)));"###")}
« Последнее редактирование: 11 Февраль 2013, 00:20 от Hasim » Записан
Leojse
Участник
**
Offline Offline

Сообщений: 12


« Ответ #4: 11 Февраль 2013, 17:10 »

Hasim, большущее СПАСИБО!
Записан
Hasim
Форумчанин
***
Offline Offline

Сообщений: 754


Woe from wit


« Ответ #5: 11 Февраль 2013, 23:04 »

В файле есть формула массива, которая складывает соответственно числа, разделенные знаком "/" (не деление).
То есть, фактически то была задачка по сложению отдельно числителей и отдельно знаменателей дробей.

А вот как именно сложить все эти дроби (и, конечно, сократить результирующую дробь)?

1/12 + 3/8 + 7/44 = 163/264



[вложение удалено Администратором]
Записан
Leojse
Участник
**
Offline Offline

Сообщений: 12


« Ответ #6: 3 Март 2013, 16:31 »

Добрый день. Возник вопрос по формуле для calc... В диапазоне встречаются пустые ячейки и формула массива показывает "ЗНАЧ". Можно ли как-то подредактировать формулу массива, чтобы формула игнорировала пустые ячейки?
Записан
Leojse
Участник
**
Offline Offline

Сообщений: 12


« Ответ #7: 5 Март 2013, 20:51 »

Добрый вечер. Пожалуйста, помогите с моей задачкой)
Если нужно могу приложить опять же экселевские формулы, которые отбрасывают пустые ячейки.

=СУММ(ЕСЛИ(ЕПУСТО(A1:A10);;--ПСТР(ПОДСТАВИТЬ(A1:A10;"/";ПОВТОР(" ";20));1;20)))&"/"&СУММ(ЕСЛИ(ЕПУСТО(A1:A10);;--ПСТР(ПОДСТАВИТЬ(A1:A10;"/";ПОВТОР(" ";20));20;20)))

=СУММ(ЕСЛИ(НЕ(ЕОШ(ПОИСК("/";A1:A10)));--ПСТР(A1:A10;1;ПОИСК("/";A1:A10)-1)))&"/"&СУММ(ЕСЛИ(НЕ(ЕОШ(ПОИСК("/";A1:A10)));--ПСТР(A1:A10;ПОИСК("/";A1:A10)+1;300)))
Записан
Hasim
Форумчанин
***
Offline Offline

Сообщений: 754


Woe from wit


« Ответ #8: 5 Март 2013, 23:25 »


=TEXT(SUM(IF(ISBLANK(A1:B12);"";VALUE(MID(A1:B12;1;SEARCH("/";A1:B12;1)-1))));"###")&"/"&TEXT(SUM(IF(ISBLANK(A1:B12);"";VALUE(MID(A1:B12;SEARCH("/";A1:B12;1)+1;LEN(A1:B12)-SEARCH("/";A1:B12;1)+1))));"###")
« Последнее редактирование: 7 Март 2013, 09:29 от Hasim » Записан
Leojse
Участник
**
Offline Offline

Сообщений: 12


« Ответ #9: 6 Март 2013, 17:35 »

Hasim, спасибо Вам за ваше внимание, но формула почему-то выдает ошибку: "Ошибка:511" и ничего не считается(
Записан
Hasim
Форумчанин
***
Offline Offline

Сообщений: 754


Woe from wit


« Ответ #10: 6 Март 2013, 18:40 »

Я же уже писал - прикладывайте ваш проблемный файл и указывайте точно, где и что не так!

Угадывать, что , где  и как у вас написано - задачка та еще.

Вот файл, на котором я упражнялся.

Что и где не так?



[вложение удалено Администратором]
« Последнее редактирование: 6 Март 2013, 18:42 от Hasim » Записан
Leojse
Участник
**
Offline Offline

Сообщений: 12


« Ответ #11: 6 Март 2013, 19:51 »

Hasim, все у Вас нормально, но дело в том, что в сообщении №8 не влезла часть формулы:
-SEARCH("/";A1:B12;1)+1))));"###")
Вот и выдавалась ошибка, что не хватает аргументов.
Большое Вам спасибо.
Записан
Hasim
Форумчанин
***
Offline Offline

Сообщений: 754


Woe from wit


« Ответ #12: 7 Март 2013, 09:29 »

М-да, действительно.
Исправил.
Записан
olyaflower
Участник
**
Offline Offline

Сообщений: 16


« Ответ #13: 13 Март 2013, 14:19 »

Здравствуйте, может вы мне поможете разобраться с моим Openoffice Calc, я бьюсь над ним уже 2 дня и не нахожу никакой информации что можно сделать. Мне нужно посчитать общую сумму в колонне P все 284 строки (цифры содержатся не во всех клетках), а программа считает только любые заданные 33 строки. Как можно исправить положение?
Записан
Hasim
Форумчанин
***
Offline Offline

Сообщений: 754


Woe from wit


« Ответ #14: 13 Март 2013, 14:54 »

Показать ваш файл.
Тогда мы, может быть, и поймем в чем там дело.
Записан
Страниц: 1 2 3 4 »   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!