Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

Форум поддержки пользователей. LibreOffice, Apache OpenOffice, OpenOffice.org

22 Июль 2019, 19:55 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
Новости: Часто задаваемые вопросы по LibreOffice и Apache OpenOffice.org
 
   Начало   Помощь Поиск Войти Регистрация    задать вопрос  
Страниц: 1   Вниз
  Печать  
Автор Тема: Галерея? [РЕШЕНО]  (Прочитано 7173 раз)
0 Пользователей и 1 Гость смотрят эту тему.
VlhOwn
Форумчанин
***
Offline Offline

Пол: Мужской
Расположение: Ростов-на-Дону
Сообщений: 1 076


« Стартовое сообщение: 20 Май 2010, 17:04 »

Кто-нибудь пробовал галерею с 3.1.1 - 3.2.1?
Нет возможности проверить, а глубоким вечером придется воспользоваться в режиме цейнота. Как расширение по-прежнему не ставится? В 3-ке куда его распаковывать и будет ли он с 3-кой вообще работать?
Короче, если кто-нибудь до 23:00 сможет проверить работу клипарта с 3-кой под Win, буду очень обязан.
« Последнее редактирование: 6 Июнь 2010, 09:52 от Syzygy » Записан
Syzygy
Форумчанин
***
Offline Offline

Пол: Мужской
Расположение: Подмосковье
Сообщений: 1 522


WWW
« Ответ #1: 20 Май 2010, 17:10 »

Непонимающий Ничего не понял. Чего надо-то? О какой Галерее идёт речь? Галерея - хранилище мультимедийных объетов и графики для ООо. Вполне себе работает.
Если речь о клипарте, который поставлялся очень давно в комплекте с ООо Professional, то не знаю (но знать точно буду через полчасика-час). Впрочем, есть обходной путь - скачать OpenClipart - там все картинки есть, можно пользоваться.

Брать отсюда: http://download.i-rs.ru/pub/openoffice/clipart/openclipart-png-ru_0.1.oxt

Update: Полевые испытания показали, что тройкой он в виде расширения напрочь игнорится.
Update2: Продолжившиеся испытания установили, что нужно положить расширение в папку  C:\Program Files\OpenOffice.org 3\Basis\share\gallery - клипарт будет доступен. Правда, темы будут продублированы, но пользоваться можно будет.
Update3: Не рекомендую удалять темы напрямую из Галереи - ООо от этого падает.
« Последнее редактирование: 20 Май 2010, 20:07 от Syzygy » Записан

A Matter of Life and Death
dr.Faust
Администратор
**
Offline Offline

Пол: Мужской
Расположение: Ростов-на-Дону
Сообщений: 1 340


« Ответ #2: 20 Май 2010, 19:49 »

А если просто сложить в C:\Program Files\OpenOffice.org 3\Basis\share\gallery ?
Записан

Свобода информации - свобода личности!
Syzygy
Форумчанин
***
Offline Offline

Пол: Мужской
Расположение: Подмосковье
Сообщений: 1 522


WWW
« Ответ #3: 20 Май 2010, 20:06 »

А если просто сложить в C:\Program Files\OpenOffice.org 3\Basis\share\gallery ?
Хм... работает! Задача упростилась.
Записан

A Matter of Life and Death
dr.Faust
Администратор
**
Offline Offline

Пол: Мужской
Расположение: Ростов-на-Дону
Сообщений: 1 340


« Ответ #4: 20 Май 2010, 20:53 »

отож...
Записан

Свобода информации - свобода личности!
VlhOwn
Форумчанин
***
Offline Offline

Пол: Мужской
Расположение: Ростов-на-Дону
Сообщений: 1 076


« Ответ #5: 20 Май 2010, 23:13 »

Спасибо огромное! Сэкономили мне полчаса очень ценного (в сложившейся ситуации) времени! Спасибо, мужики!
Записан
Nick222
Форумчанин
***
Offline Offline

Сообщений: 171


« Ответ #6: 29 Июнь 2011, 09:33 »

В ЛО 3.3.3 при попытке добавить файлы из OpenClipArt руками в галерею - через "Создать тему" (в галерее) - "Найти файлы" - "Добавить всё" - по одному файлу добавляется, при нескольких файлах:
- попытка добавления PNG - отжирает 3,2 Гб виртуальной памяти и виснет;
- попытка добавления SVG - отжирает 90% процессора и ничего;

Посоветуйте, плз, как добавить.

Или пока вменяемого расширения клипарта для ЛО нет?

P.S.: Под Линукс я не могу скопировать в папку, как советуется выше, там папки другие - может куда в другое место можно скопировать для автоматического "подцепляния" (у меня PNG в галерее все есть, а SVG нет вообще)?
Записан

Xubuntu 18.04-64, LibreOffice 6.*.*
Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #7: 29 Июнь 2011, 11:28 »

В ЛО 3.3.3 при попытке добавить файлы из OpenClipArt руками в галерею - через "Создать тему" (в галерее) - "Найти файлы" - "Добавить всё" - по одному файлу добавляется, при нескольких файлах:
- попытка добавления PNG - отжирает 3,2 Гб виртуальной памяти и виснет;
- попытка добавления SVG - отжирает 90% процессора и ничего;
Не могу сейчас проверить на 3.3.3 , но на 3.4.1rc2(Win Vista) всё ОК.
Кстати, файлы можно добавлять и из самого документа. Для этого нужно зажать левую кнопку мышки на изображении в документе и подержав её около 3 секунд, перетащить изображение в галерею. Т.е., можно выделить в проводнике все нужные изображения, Ctrl C в проводнике, Ctrl V в Draw, а потом по одному их перетаскивать в галерею. А если это изабражения в формате odg, то это вообще наверное единственный способ
« Последнее редактирование: 29 Июнь 2011, 11:30 от Клио » Записан

ubuntu 12.04 + LibO3.6.0
Nick222
Форумчанин
***
Offline Offline

Сообщений: 171


« Ответ #8: 29 Июнь 2011, 12:38 »

Мне нужно добавить все SVG, что были в OpenClipArt и не вставились в галерею в предыдущей версии - так что руками не катит Грустный
Записан

Xubuntu 18.04-64, LibreOffice 6.*.*
Рыбка Рио
Форумчанин
***
Offline Offline

Сообщений: 1 678


« Ответ #9: 29 Июнь 2011, 21:50 »

LibO 3.3.3 + Ubuntu 10.04 всё ОК
(и с svg и с png всё ОК: создаю новую тему, добавляю 153 svg и порядка 10 png)
Записан

ubuntu 12.04 + LibO3.6.0
Nick222
Форумчанин
***
Offline Offline

Сообщений: 171


« Ответ #10: 30 Июнь 2011, 08:23 »

У меня 11.04 ...
Записан

Xubuntu 18.04-64, LibreOffice 6.*.*
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!